Salome HOME
Merge from V6_main_20120808 08Aug12
[modules/smesh.git] / src / DriverMED / Makefile.am
index 3207132f87c5308cfb3828cd56b7f184e66e7c99..898952af77ff2948b7bfdc21933b42eb1f692ac8 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 #
+
 #  SMESH DriverMED : driver to read and write 'med' files
 #  File   : Makefile.in
 #  Author : Marc Tajchman (CEA)
 #  SMESH DriverMED : driver to read and write 'med' files
 #  File   : Makefile.in
 #  Author : Marc Tajchman (CEA)
@@ -30,23 +28,15 @@ include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
 
 # header files 
 salomeinclude_HEADERS = \
-       DriverMED_R_SMDS_Mesh.h \
        DriverMED_R_SMESHDS_Mesh.h \
        DriverMED_R_SMESHDS_Mesh.h \
-       DriverMED_R_SMESHDS_Document.h \
-       DriverMED_W_SMDS_Mesh.h \
        DriverMED_W_SMESHDS_Mesh.h \
        DriverMED_W_SMESHDS_Mesh.h \
-       DriverMED_W_SMESHDS_Document.h \
        DriverMED_Family.h \
        SMESH_DriverMED.hxx
 
 # Libraries targets
 lib_LTLIBRARIES = libMeshDriverMED.la
 dist_libMeshDriverMED_la_SOURCES = \
        DriverMED_Family.h \
        SMESH_DriverMED.hxx
 
 # Libraries targets
 lib_LTLIBRARIES = libMeshDriverMED.la
 dist_libMeshDriverMED_la_SOURCES = \
-       DriverMED_R_SMDS_Mesh.cxx \
        DriverMED_R_SMESHDS_Mesh.cxx \
        DriverMED_R_SMESHDS_Mesh.cxx \
-       DriverMED_R_SMESHDS_Document.cxx \
-       DriverMED_W_SMDS_Mesh.cxx \
-       DriverMED_W_SMESHDS_Document.cxx \
        DriverMED_W_SMESHDS_Mesh.cxx \
        DriverMED_Family.cxx
 
        DriverMED_W_SMESHDS_Mesh.cxx \
        DriverMED_Family.cxx
 
@@ -63,15 +53,16 @@ libMeshDriverMED_la_CPPFLAGS = \
        @HDF5_INCLUDES@ \
        $(KERNEL_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
        @HDF5_INCLUDES@ \
        $(KERNEL_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../SMDS \
        $(BOOST_CPPFLAGS) \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../SMDS \
-       -I$(srcdir)/../SMESHDS \
-       -I$(top_builddir)/salome_adm/unix
+       -I$(srcdir)/../SMESHDS
 
 libMeshDriverMED_la_LDFLAGS  = \
 
 libMeshDriverMED_la_LDFLAGS  = \
+       $(BOOST_LIBS) \
        ../Driver/libMeshDriver.la \
        ../Driver/libMeshDriver.la \
-       $(MED_LDFLAGS) -lMEDWrapper
+       $(MED_LDFLAGS) -lMEDWrapper -lMEDWrapperBase -lMEDWrapper_V2_2 -lMEDWrapper_V2_1
 
 
 MED_Test_CPPFLAGS = \
 
 
 MED_Test_CPPFLAGS = \
@@ -89,7 +80,6 @@ MED_Test_LDADD = \
        $(MED_LDFLAGS) \
        -lMEDWrapper \
        -lMEDWrapperBase \
        $(MED_LDFLAGS) \
        -lMEDWrapper \
        -lMEDWrapperBase \
-       -lMEDWrapper_V2_1 \
-       -lmed_V2_1 \
-       -lMEDWrapper_V2_2
+       -lMEDWrapper_V2_2 \
+       -lMEDWrapper_V2_1