Salome HOME
PR: synchro V7_main tag mergefrom_V6_main_06Mar13
[modules/smesh.git] / src / DriverMED / Makefile.am
index 97c53f576c193dd1672a554b4d525dbf2dd55ef0..2e858e471e3ad16ff08d8d6d3970970071053537 100644 (file)
@@ -1,50 +1,40 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 
 #  SMESH DriverMED : driver to read and write 'med' files
 #  File   : Makefile.in
 #  Author : Marc Tajchman (CEA)
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-#  $Header$
 #
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
-       DriverMED_R_SMDS_Mesh.h \
        DriverMED_R_SMESHDS_Mesh.h \
-       DriverMED_R_SMESHDS_Document.h \
-       DriverMED_W_SMDS_Mesh.h \
        DriverMED_W_SMESHDS_Mesh.h \
-       DriverMED_W_SMESHDS_Document.h \
        DriverMED_Family.h \
        SMESH_DriverMED.hxx
 
 # Libraries targets
 lib_LTLIBRARIES = libMeshDriverMED.la
 dist_libMeshDriverMED_la_SOURCES = \
-       DriverMED_R_SMDS_Mesh.cxx \
        DriverMED_R_SMESHDS_Mesh.cxx \
-       DriverMED_R_SMESHDS_Document.cxx \
-       DriverMED_W_SMDS_Mesh.cxx \
-       DriverMED_W_SMESHDS_Document.cxx \
        DriverMED_W_SMESHDS_Mesh.cxx \
        DriverMED_Family.cxx
 
@@ -65,13 +55,14 @@ libMeshDriverMED_la_CPPFLAGS = \
        $(BOOST_CPPFLAGS) \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../SMDS \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESHDS
 
 libMeshDriverMED_la_LDFLAGS  = \
        $(BOOST_LIBS) \
        ../Driver/libMeshDriver.la \
        $(MED_LDFLAGS) -lMEDWrapper -lMEDWrapperBase -lMEDWrapper_V2_2
-
+       $(BOOST_LIB_SYSTEM) 
 
 MED_Test_CPPFLAGS = \
        $(libMeshDriverMED_la_CPPFLAGS)
@@ -81,6 +72,7 @@ MED_Test_LDADD = \
        ../Driver/libMeshDriver.la \
        ../SMDS/libSMDS.la \
        ../SMESHDS/libSMESHDS.la \
+       ${BOOST_LIB_SYSTEM} \
        $(KERNEL_LDFLAGS) \
        -lOpUtil \
        -lSALOMELocalTrace \
@@ -89,4 +81,4 @@ MED_Test_LDADD = \
        -lMEDWrapper \
        -lMEDWrapperBase \
        -lMEDWrapper_V2_2
-
+       $(BOOST_LIB_SYSTEM)