Salome HOME
Merge from V6_main (04/10/2012)
[modules/smesh.git] / src / Driver / Makefile.am
index 9ee19313650c045f2fea041560214da391bb5634..a088c773a75ecab364db7bf60599330b27134e3c 100644 (file)
@@ -1,32 +1,29 @@
-#  SMESH Driver : implementaion of driver for reading and writing      
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+#
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
+#  SMESH Driver : implementaion of driver for reading and writing      
 #  File   : Makefile.in
 #  Author : Marc Tajchman (CEA)
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
 #  $Header$
-
+#
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
@@ -47,11 +44,13 @@ dist_libMeshDriver_la_SOURCES = \
 
 # additionnal information to compil and link file
 libMeshDriver_la_CPPFLAGS = \
+        $(BOOST_CPPFLAGS) \
        $(CAS_CPPFLAGS) \
        $(KERNEL_CXXFLAGS) \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESHDS  
 
 libMeshDriver_la_LDFLAGS  = \
        ../SMESHDS/libSMESHDS.la \
        $(KERNEL_LDFLAGS) -lOpUtil \
-       $(CAS_LDPATH) -TKernel -lTKTopAlgo
+       $(CAS_LDPATH) -lTKernel -lTKTopAlgo