Salome HOME
Update of CheckDone
[modules/smesh.git] / src / Controls / CMakeLists.txt
index b3339614869e5f770b1edaec741473e0dd2509f8..edf0955ba1769b1fd62a86be656279a958d62d4b 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2024  CEA, EDF, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -20,8 +20,7 @@
 # --- options ---
 # additional include directories
 INCLUDE_DIRECTORIES(
-  ${CAS_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${Boost_INCLUDE_DIRS}
   ${KERNEL_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/SMDS
@@ -31,35 +30,20 @@ INCLUDE_DIRECTORIES(
 
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
 # libraries to link to
 SET(_link_LIBRARIES
-  ${VTK_LIBRARIES}
-  ${CAS_TKernel}
-  ${CAS_TKBRep}
-  ${CAS_TKG3d}
-  ${CAS_TKTopAlgo}
-  ${CAS_TKGeomBase}
-  ${CAS_TKGeomAlgo}
+  ${OpenCASCADE_FoundationClasses_LIBRARIES}
+  ${OpenCASCADE_ModelingData_LIBRARIES}
+  ${OpenCASCADE_ModelingAlgorithms_LIBRARIES}
+  ${GEOM_GEOMUtils}
   SMDS
   SMESHDS
   SMESHUtils
-)
-
-SET(_link_LIBRARIES_bin
-  ${KERNEL_OpUtil}
-  ${KERNEL_SALOMELocalTrace}
-  ${KERNEL_SALOMEBasics}
-  ${KERNEL_SalomeIDLKERNEL}
-  ${GEOM_GEOMAlgo}
-  ${CAS_TKernel}
-  ${CAS_TKBRep}
-  ${CAS_TKG3d}
-  SMDS
-  SMESHDS
+  VTK::FiltersVerdict
 )
 
 # --- headers ---
@@ -76,20 +60,10 @@ SET(SMESHControls_SOURCES
   SMESH_Controls.cxx 
 )
 
-# bin programs
-SET(SMESHControls_bin_SOURCES
-  SMESHControls.cxx
-)
-
 # --- rules ---
 
 ADD_LIBRARY(SMESHControls ${SMESHControls_SOURCES})
 TARGET_LINK_LIBRARIES(SMESHControls ${_link_LIBRARIES} )
 INSTALL(TARGETS SMESHControls EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
-ADD_EXECUTABLE(SMESHControls_bin ${SMESHControls_bin_SOURCES})
-TARGET_LINK_LIBRARIES(SMESHControls_bin ${_link_LIBRARIES_bin} SMESHControls)
-SET_TARGET_PROPERTIES(SMESHControls_bin PROPERTIES OUTPUT_NAME "SMESHControls")
-INSTALL(TARGETS SMESHControls_bin EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
-
 INSTALL(FILES ${SMESHControls_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})