Salome HOME
correction des valeurs
[modules/smesh.git] / src / Controls / CMakeLists.txt
index 85b95d4c4a8efa9914772b0d772c2bc6a1244cfc..b90e2b23b091dbac7cbdced0300249158f093154 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2019  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2021  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -21,7 +21,6 @@
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${OpenCASCADE_INCLUDE_DIR}
-  ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
   ${KERNEL_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/SMDS
@@ -37,13 +36,14 @@ ADD_DEFINITIONS(
 
 # libraries to link to
 SET(_link_LIBRARIES
-  ${VTK_LIBRARIES}
   ${OpenCASCADE_FoundationClasses_LIBRARIES}
   ${OpenCASCADE_ModelingData_LIBRARIES}
   ${OpenCASCADE_ModelingAlgorithms_LIBRARIES}
+  ${GEOM_GEOMUtils}
   SMDS
   SMESHDS
   SMESHUtils
+  VTK::FiltersVerdict
 )
 
 # --- headers ---