Salome HOME
Copyright update: 2016
[modules/smesh.git] / src / Controls / CMakeLists.txt
index b3339614869e5f770b1edaec741473e0dd2509f8..74798ca6756f6c46972d8d757574266402d14798 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -49,19 +49,6 @@ SET(_link_LIBRARIES
   SMESHUtils
 )
 
-SET(_link_LIBRARIES_bin
-  ${KERNEL_OpUtil}
-  ${KERNEL_SALOMELocalTrace}
-  ${KERNEL_SALOMEBasics}
-  ${KERNEL_SalomeIDLKERNEL}
-  ${GEOM_GEOMAlgo}
-  ${CAS_TKernel}
-  ${CAS_TKBRep}
-  ${CAS_TKG3d}
-  SMDS
-  SMESHDS
-)
-
 # --- headers ---
 
 # header files / no moc processing
@@ -76,20 +63,10 @@ SET(SMESHControls_SOURCES
   SMESH_Controls.cxx 
 )
 
-# bin programs
-SET(SMESHControls_bin_SOURCES
-  SMESHControls.cxx
-)
-
 # --- rules ---
 
 ADD_LIBRARY(SMESHControls ${SMESHControls_SOURCES})
 TARGET_LINK_LIBRARIES(SMESHControls ${_link_LIBRARIES} )
 INSTALL(TARGETS SMESHControls EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
-ADD_EXECUTABLE(SMESHControls_bin ${SMESHControls_bin_SOURCES})
-TARGET_LINK_LIBRARIES(SMESHControls_bin ${_link_LIBRARIES_bin} SMESHControls)
-SET_TARGET_PROPERTIES(SMESHControls_bin PROPERTIES OUTPUT_NAME "SMESHControls")
-INSTALL(TARGETS SMESHControls_bin EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
-
 INSTALL(FILES ${SMESHControls_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})