Salome HOME
Modify fmod() by '%' operator to operate with integers.
[modules/smesh.git] / resources / Makefile.am
index 2593cf94ca92ae54ba92e2da8b79417b06b3d2d9..5c804268b001bbb064525e1c0fe6dbd516e60695 100644 (file)
@@ -1,4 +1,6 @@
-#  Copyright (C) 2005  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
+#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+#
+#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
 #  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
 #
 #  This library is free software; you can redistribute it and/or
 #  License along with this library; if not, write to the Free Software
 #  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 # -* Makefile *- 
-#
 # Author : Patrick GOLDBRONN (CEA)
 # Date : 28/06/2001
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 # $Header$
 #
-
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 dist_salomeres_DATA = \
@@ -39,11 +39,10 @@ dist_salomeres_DATA = \
        mesh_area.png \
        mesh_aspect.png \
        mesh_aspect_3d.png \
+       mesh_clear.png \
        mesh_compute.png \
-       mesh_connectivity.png \
        mesh_diagonal.png \
        mesh_edit.png \
-       mesh_hexa_n.png \
        mesh_hexa.png \
        mesh_hypo_area.png \
        mesh_hypo_length.png \
@@ -53,6 +52,7 @@ dist_salomeres_DATA = \
        mesh_info.png \
        advanced_mesh_info.png \
        standard_mesh_info.png \
+       mesh_whatis.png \
        mesh_init.png \
        mesh_length.png \
        mesh_length_2d.png \
@@ -73,13 +73,10 @@ dist_salomeres_DATA = \
        mesh_quad.png \
        mesh_rem_element.png \
        mesh_rem_node.png \
-       mesh_set_algo.png \
-       mesh_set_hypo.png \
        mesh_shading.png \
        mesh_shrink.png \
        mesh_skew.png \
        mesh_taper.png \
-       mesh_tetra_n.png \
        mesh_tetra.png \
        mesh_tree_algo_hexa.png \
        mesh_tree_algo_mefisto.png \
@@ -87,15 +84,11 @@ dist_salomeres_DATA = \
        mesh_tree_algo_quad.png \
        mesh_tree_algo_regular.png \
        mesh_tree_algo_tetra.png \
-       mesh_tree_algo_netgen_2d3d.png \
-       mesh_tree_algo_netgen_2d.png \
        mesh_tree_hypo_area.png \
        mesh_tree_hypo_length.png \
        mesh_tree_hypo.png \
        mesh_tree_hypo_segment.png \
        mesh_tree_hypo_volume.png \
-       mesh_tree_hypo_netgen.png \
-       mesh_tree_hypo_netgen_2d.png \
        mesh_tree_mesh.png \
        mesh_tree_importedmesh.png \
        mesh_tree_mesh_warn.png \
@@ -108,9 +101,11 @@ dist_salomeres_DATA = \
        mesh_wireframe.png \
        mesh_points.png \
        mesh_wrap.png \
+       mesh_group.png \
        mesh_tree_group.png \
        mesh_edit_group.png \
        mesh_make_group.png \
+       mesh_groups_from_gemetry.png \
        mesh_union2tri.png \
        mesh_uniontri.png \
        mesh_cutquad.png \
@@ -138,10 +133,7 @@ dist_salomeres_DATA = \
        mesh_merge_nodes.png \
        mesh_merge_elements.png \
        select1.png \
-       SMESH_en.xml \
-       SMESH.config \
        StdMeshers.xml \
-       SMESHCatalog.xml \
        SalomeApp.xml \
        mesh_pattern.png \
        pattern_sample_2d.png \
@@ -158,7 +150,6 @@ dist_salomeres_DATA = \
        mesh_conv_to_quad.png \
        mesh_tree_hypo_layers_distribution.png \
        mesh_tree_algo_radial_prism.png \
-       mesh_tree_algo_projection_3d.png \
        mesh_tree_algo_projection_2d.png \
        mesh_hypo_source_edge.png \
        mesh_hypo_source_3d.png \
@@ -168,6 +159,10 @@ dist_salomeres_DATA = \
        mesh_tree_hypo_source_edge.png \
        mesh_tree_hypo_source_3d_shape.png \
        mesh_tree_hypo_projection_3d.png \
-       mesh_tree_hypo_projection_2d.png
+       mesh_tree_hypo_projection_2d.png \
+       mesh_build_compound.png \
+       mesh_node_to_point.png \
+       mesh_tree_mesh_partial.png
 
-nodist_salomeres_DATA = SMESHCatalog.xml
+# VSR: little trick to avoid putting if SMESHCatalog.xml to the distribution archive
+nodist_salomeres_SCRIPTS = SMESHCatalog.xml