Salome HOME
PR: create flat elements on face groups (ASTER calculations)
[modules/smesh.git] / idl / Makefile.am
index 03486bd078c5826f0c33e3afb18cb3b8e58909d2..491c38667fe62ed1838fff01371b6ddf84729c18 100644 (file)
@@ -1,7 +1,4 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
-#
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 #  This library is free software; you can redistribute it and/or
 #  modify it under the terms of the GNU Lesser General Public
@@ -19,6 +16,7 @@
 #
 #  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 # This Makefile is responsible of generating the client and server
 # implementation of IDL interfaces for both C++ and python usage.
 # The building process of the C++ files is in charge of each source
@@ -34,7 +32,8 @@ BASEIDL_FILES = \
        SMESH_Filter.idl \
        SMESH_Group.idl \
        SMESH_Pattern.idl \
-       SMESH_MeshEditor.idl
+       SMESH_MeshEditor.idl \
+       SMESH_Measurements.idl
 
 # This variable defines the files to be installed
 dist_salomeidl_DATA = $(BASEIDL_FILES)
@@ -51,7 +50,8 @@ nodist_libSalomeIDLSMESH_la_SOURCES = \
        SMESH_FilterSK.cc \
        SMESH_GroupSK.cc \
        SMESH_PatternSK.cc \
-       SMESH_MeshEditorSK.cc
+       SMESH_MeshEditorSK.cc \
+       SMESH_MeasurementsSK.cc
 
 # header files must be exported: other modules have to use this library
 nodist_salomeinclude_HEADERS = $(BASEIDL_FILES:%.idl=%.hh)