Salome HOME
Merge from V6_main_20120808 08Aug12
[modules/smesh.git] / doc / salome / tui / Makefile.am
index b8cd5eee5a651a9200cd2e499cf9a059969d015c..987d26a43615ea2d85187e6e40b642ac3c4f5c64 100644 (file)
@@ -1,39 +1,32 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  File   : Makefile.in
 #  Author : Vasily Rusyaev (Open Cascade NN)
 #  Module : doc
 #
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
-EXTRA_DIST += images static
-
-dist_doc_DATA = \
-       extra/AddNetgenInSalome2.pdf    \
-       extra/AddNetgenInSalome2.ps     \
-       extra/AddNetgenInSalome2.sxw    \
-       extra/PluginMeshers.html
+EXTRA_DIST += input images static/doxygen.css static/footer.html
 
-EXTRA_DIST += extra/PluginMeshers.txt
+tuidocdir = $(docdir)/tui/SMESH
+tuidoc_DATA = images/head.png images/smeshscreen.png
 
 dev_docs: doxyfile
        echo "Running doxygen in directory: "`pwd`; \
@@ -49,4 +42,13 @@ install-data-local:
        fi;
 
 uninstall-local:
-       rm -rf $(DESTDIR)$(docdir)/tui/SMESH
+       @test -d $(DESTDIR)$(tuidocdir) && chmod -R +w $(DESTDIR)$(tuidocdir) ; \
+       for filen in `find $(DESTDIR)$(tuidocdir) -mindepth 1 -maxdepth 1` dummy ; do \
+         case $${filen} in \
+           dummy ) ;; \
+           $(DESTDIR)$(tuidocdir)/docutils ) ;; \
+           $(DESTDIR)$(tuidocdir)/head.png ) ;; \
+           $(DESTDIR)$(tuidocdir)/smeshscreen.png ) ;; \
+           * ) echo "removing $${filen}" && rm -rf $${filen} ;; \
+         esac ; \
+       done