Salome HOME
Merge from V5_1_5_BR branch 12/11/2010
[modules/smesh.git] / doc / salome / gui / SMESH / Makefile.am
index 8c4ce20034d17e0b5fb7806acf3d72d9f60519d1..1bb1e9beeb5951b492bb0ab8592dd14cb023bef6 100755 (executable)
@@ -1,7 +1,4 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
-#
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 #  This library is free software; you can redistribute it and/or
 #  modify it under the terms of the GNU Lesser General Public
@@ -19,6 +16,7 @@
 #
 #  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  File   : Makefile.in
 #  Author : Vasily Rusyaev (Open Cascade NN)
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
@@ -33,42 +31,40 @@ guidoc_DATA = images/head.png
 
 
 usr_docs: doxyfile_py doxyfile 
-       echo "===========================================" ;            \
-       echo "Generating Python interface documentation";               \
-       echo "===========================================" ;            \
-       $(DOXYGEN) doxyfile_py ;                                        \
-       echo "===========================================" ;            \
-       echo "Replacing smeshDC by smesh" ;                             \
-       echo "===========================================" ;            \
-       files=`find smeshpy_doc -type f` ;                              \
-       for filen in $${files} ; do                                     \
-         sed -e "s/\<smeshDC\>/smesh/g" -e "s/smesh\.smesh/smesh/g"    \
-             -e "s/smesh::smesh/smesh/g" $${filen} > $${filen}_ ;      \
-         mv -f $${filen}_ $${filen} ;                                  \
-       done ;                                                          \
-       echo "===========================================" ;            \
-       echo "Generating GUI documentation" ;                           \
-       echo "===========================================" ;            \
-       $(DOXYGEN) doxyfile ;
+       echo "===========================================" ;                    \
+       echo "Replacing smeshDC by smesh" ;                                     \
+       echo "===========================================" ;                    \
+       sed -e "/class smeshDC/d" -e "s/^ *#/#/g" -e "s/^ *def /def /g"         \
+         -e "s/smeshDC/smesh/g" $(top_srcdir)/src/SMESH_SWIG/smeshDC.py >      \
+         $(top_builddir)/src/SMESH_SWIG/smesh.py ;                             \
+       echo "===========================================" ;                    \
+       echo "Generating Python interface documentation";                       \
+       echo "===========================================" ;                    \
+       $(DOXYGEN) doxyfile_py ;                                                \
+       echo "===========================================" ;                    \
+       echo "Generating GUI documentation" ;                                   \
+       echo "===========================================" ;                    \
+       $(DOXYGEN) doxyfile ;                                                   \
+       rm -f $(top_builddir)/src/SMESH_SWIG/smesh.py
 
 docs: usr_docs
 
 clean-local:
-       @for filen in `find . -maxdepth 1` ; do                         \
+       @for filen in `find . -maxdepth 1` ; do                 \
          case $${filen} in                                     \
            ./Makefile | ./doxyfile | ./doxyfile_py ) ;;        \
-           . | .. ) ;;                                         \
+           . | .. | ./static ) ;;                              \
            *) echo "Removing $${filen}" ; rm -rf $${filen} ;;  \
          esac ;                                                \
        done ;
 
 install-data-local: usr_docs
        $(INSTALL) -d $(DESTDIR)$(docdir)/gui/SMESH
-       @for filen in `find . -maxdepth 1` ; do                                                         \
+       @for filen in `find . -maxdepth 1` ; do                                                 \
          case $${filen} in                                                                     \
            ./Makefile | ./doxyfile | ./doxyfile_py ) ;;                                        \
            ./doxyfile.bak | ./doxyfile_py.bak ) ;;                                             \
-           . | .. ) ;;                                                                         \
+           . | .. | ./static ) ;;                                                              \
            *) echo "Installing $${filen}" ; cp -rp $${filen} $(DESTDIR)$(docdir)/gui/SMESH ;;  \
          esac ;                                                                                \
        done ;