Salome HOME
Merge from V6_3_BR 06/06/2011
[modules/smesh.git] / doc / docutils / Makefile.am
index 573f4a4f0b57801ca3329374080ea956d06046b2..eeec2fbf98fe05a66fe514212fb643cfb5c8d744 100644 (file)
@@ -1,37 +1,36 @@
 #  -*- coding: iso-8859-1 -*-
 #  -*- coding: iso-8859-1 -*-
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
+# CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
 #
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+#
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 pydocdir = $(docdir)/tui/SMESH/docutils
 
 
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 pydocdir = $(docdir)/tui/SMESH/docutils
 
-.PHONY : latex
-
-if SPHINX_IS_OK
-
-html/index.html:$(RSTFILES)
-       make htm
+RSTFILES = \
+       index.rst \
+       overview.rst \
+       docapi.rst
 
 
-endif
+EXTRA_DIST += $(RSTFILES)
 
 SPHINXOPTS      =
 SOURCEDIR       = $(srcdir)
 
 SPHINXOPTS      =
 SOURCEDIR       = $(srcdir)
@@ -43,7 +42,12 @@ SPHINX_PYTHONPATH = $(prefix)/lib/python$(PYTHON_VERSION)/site-packages/salome:$
 
 SPHINX_LD_LIBRARY_PATH = $(KERNEL_ROOT_DIR)/lib/salome:$(OMNIORB_ROOT)/lib
 
 
 SPHINX_LD_LIBRARY_PATH = $(KERNEL_ROOT_DIR)/lib/salome:$(OMNIORB_ROOT)/lib
 
-htm:
+
+.PHONY: latex
+
+if SPHINX_IS_OK
+
+html/index.html:$(RSTFILES)
        mkdir -p html doctrees
        PYTHONPATH=$(SPHINX_PYTHONPATH):${PYTHONPATH} \
        LD_LIBRARY_PATH=$(SPHINX_LD_LIBRARY_PATH):${LD_LIBRARY_PATH} \
        mkdir -p html doctrees
        PYTHONPATH=$(SPHINX_PYTHONPATH):${PYTHONPATH} \
        LD_LIBRARY_PATH=$(SPHINX_LD_LIBRARY_PATH):${LD_LIBRARY_PATH} \
@@ -51,6 +55,13 @@ htm:
        @echo
        @echo "Build finished. The HTML pages are in html."
 
        @echo
        @echo "Build finished. The HTML pages are in html."
 
+else
+
+html/index.html:
+       @echo "Documentation for Python package not built. Sphinx was not present at configure time."
+
+endif
+
 latex:
        mkdir -p latex doctrees
        PYTHONPATH=$(SPHINX_PYTHONPATH):${PYTHONPATH} \
 latex:
        mkdir -p latex doctrees
        PYTHONPATH=$(SPHINX_PYTHONPATH):${PYTHONPATH} \
@@ -61,16 +72,6 @@ latex:
        @echo "Run \`make all-pdf' or \`make all-ps' in that directory to" \
              "run these through (pdf)latex."
 
        @echo "Run \`make all-pdf' or \`make all-ps' in that directory to" \
              "run these through (pdf)latex."
 
-html:
-       mkdir -p $@
-
-RSTFILES= \
-       index.rst \
-       overview.rst \
-       docapi.rst
-
-EXTRA_DIST+= $(RSTFILES)
-
 install-data-local: html/index.html
        test -z $(pydocdir) || mkdir -p $(DESTDIR)$(pydocdir)
        if test -d "html"; then b=; else b="$(srcdir)/"; fi; \
 install-data-local: html/index.html
        test -z $(pydocdir) || mkdir -p $(DESTDIR)$(pydocdir)
        if test -d "html"; then b=; else b="$(srcdir)/"; fi; \
@@ -84,5 +85,5 @@ clean-local:
        -rm -rf html latex doctrees
        if test -d "html"; then rm -rf html ; fi
 
        -rm -rf html latex doctrees
        if test -d "html"; then rm -rf html ; fi
 
-disthook :
+dist-hook:
        -test -d html && cp -Rp html $(distdir)
        -test -d html && cp -Rp html $(distdir)