Salome HOME
Join modifications from BR_Dev_For_4_0 tag V4_1_1.
[modules/smesh.git] / src / SMESHDS / Makefile.am
diff --git a/src/SMESHDS/Makefile.am b/src/SMESHDS/Makefile.am
new file mode 100644 (file)
index 0000000..23da89e
--- /dev/null
@@ -0,0 +1,70 @@
+#  SMESH SMESHDS : management of mesh data and SMESH document
+#
+#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
+#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
+# 
+#  This library is free software; you can redistribute it and/or 
+#  modify it under the terms of the GNU Lesser General Public 
+#  License as published by the Free Software Foundation; either 
+#  version 2.1 of the License. 
+# 
+#  This library is distributed in the hope that it will be useful, 
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
+#  Lesser General Public License for more details. 
+# 
+#  You should have received a copy of the GNU Lesser General Public 
+#  License along with this library; if not, write to the Free Software 
+#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
+# 
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#
+#
+#
+#  File   : Makefile.in
+#  Author : Patrick GOLDBRONN (CEA)
+#  Modified by : Alexander BORODIN (OCN) - autotools usage
+#  Module : SMESH
+
+include $(top_srcdir)/adm_local/unix/make_common_starter.am
+
+# header files 
+salomeinclude_HEADERS = \
+       SMESHDS_Document.hxx \
+       SMESHDS_Hypothesis.hxx \
+       SMESHDS_Mesh.hxx \
+       SMESHDS_Script.hxx \
+       SMESHDS_Command.hxx \
+       SMESHDS_CommandType.hxx \
+       SMESHDS_SubMesh.hxx \
+       SMESHDS_GroupBase.hxx \
+       SMESHDS_Group.hxx \
+       SMESHDS_GroupOnGeom.hxx \
+       SMESH_SMESHDS.hxx \
+       SMESHDS_DataMapOfShape.hxx
+
+# Libraries targets
+lib_LTLIBRARIES = libSMESHDS.la
+
+dist_libSMESHDS_la_SOURCES = \
+       SMESHDS_Document.cxx \
+       SMESHDS_Hypothesis.cxx \
+       SMESHDS_Script.cxx \
+       SMESHDS_Command.cxx \
+       SMESHDS_SubMesh.cxx \
+       SMESHDS_Mesh.cxx \
+       SMESHDS_GroupBase.cxx \
+       SMESHDS_Group.cxx \
+       SMESHDS_GroupOnGeom.cxx
+
+# additionnal information to compil and link file
+libSMESHDS_la_CPPFLAGS = \
+       $(KERNEL_CXXFLAGS) \
+       $(CAS_CPPFLAGS) \
+       $(BOOST_CPPFLAGS) \
+       -I$(srcdir)/../SMDS
+
+libSMESHDS_la_LDFLAGS  = \
+       ../SMDS/libSMDS.la \
+       $(KERNEL_LDFLAGS) -lSALOMELocalTrace \
+       $(CAS_KERNEL) -lTKBRep