Salome HOME
Join modifications from BR_Dev_For_4_0 tag V4_1_1.
[modules/smesh.git] / src / SMESH / Makefile.am
diff --git a/src/SMESH/Makefile.am b/src/SMESH/Makefile.am
new file mode 100644 (file)
index 0000000..8ea7e57
--- /dev/null
@@ -0,0 +1,110 @@
+#  SMESH SMESH : implementaion of SMESH idl descriptions
+#
+#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
+#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
+# 
+#  This library is free software; you can redistribute it and/or 
+#  modify it under the terms of the GNU Lesser General Public 
+#  License as published by the Free Software Foundation; either 
+#  version 2.1 of the License. 
+# 
+#  This library is distributed in the hope that it will be useful, 
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
+#  Lesser General Public License for more details. 
+# 
+#  You should have received a copy of the GNU Lesser General Public 
+#  License along with this library; if not, write to the Free Software 
+#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
+# 
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#
+#
+#
+#  File   : Makefile.in
+#  Author : Paul RASCLE, EDF
+#  Modified by : Alexander BORODIN (OCN) - autotools usage
+#  Module : SMESH
+#  $Header$
+
+include $(top_srcdir)/adm_local/unix/make_common_starter.am
+
+# header files 
+salomeinclude_HEADERS = \
+       SMESH_Gen.hxx \
+       SMESH_Mesh.hxx \
+       SMESH_subMesh.hxx \
+       SMESH_subMeshEventListener.hxx \
+       SMESH_Hypothesis.hxx \
+       SMESH_HypoFilter.hxx \
+       SMESH_Algo.hxx \
+       SMESH_0D_Algo.hxx \
+       SMESH_1D_Algo.hxx \
+       SMESH_2D_Algo.hxx \
+       SMESH_3D_Algo.hxx \
+       SMESH_Group.hxx \
+       SMESH_MeshEditor.hxx \
+       SMESH_Block.hxx \
+       SMESH_Pattern.hxx \
+       SMESH_IndexedDataMapOfShapeIndexedMapOfShape.hxx \
+       SMESH_DataMapOfElemPtrSequenceOfElemPtr.hxx \
+       SMESH_SequenceOfElemPtr.hxx \
+       SMESH_SequenceOfNode.hxx \
+       SMESH_MesherHelper.hxx \
+       SMESH_Octree.hxx \
+       SMESH_OctreeNode.hxx \
+       SMESH_Comment.hxx \
+       SMESH_ComputeError.hxx \
+       SMESH_SMESH.hxx
+
+# Libraries targets
+
+lib_LTLIBRARIES = libSMESHimpl.la
+
+dist_libSMESHimpl_la_SOURCES = \
+       SMESH_Gen.cxx \
+       SMESH_Mesh.cxx \
+       SMESH_subMesh.cxx \
+       SMESH_Hypothesis.cxx \
+       SMESH_Algo.cxx \
+       SMESH_0D_Algo.cxx \
+       SMESH_1D_Algo.cxx \
+       SMESH_2D_Algo.cxx \
+       SMESH_3D_Algo.cxx \
+       SMESH_Group.cxx \
+       SMESH_MeshEditor.cxx \
+       SMESH_Block.cxx \
+       SMESH_Pattern.cxx \
+       SMESH_HypoFilter.cxx \
+       SMESH_MesherHelper.cxx \
+       SMESH_Octree.cxx \
+       SMESH_OctreeNode.cxx
+
+# additionnal information to compile and link file
+libSMESHimpl_la_CPPFLAGS = \
+       $(KERNEL_CXXFLAGS) \
+       $(MED_CXXFLAGS) \
+       $(GEOM_CXX_FLAGS) \
+       $(BOOST_CPPFLAGS) \
+       $(CAS_CPPFLAGS) \
+       @HDF5_INCLUDES@ \
+       -I$(srcdir)/../Controls \
+       -I$(srcdir)/../Driver \
+       -I$(srcdir)/../DriverDAT \
+       -I$(srcdir)/../DriverMED \
+       -I$(srcdir)/../DriverUNV \
+       -I$(srcdir)/../DriverSTL \
+       -I$(srcdir)/../SMDS \
+       -I$(srcdir)/../SMESHDS \
+       -I$(top_builddir)/salome_adm/unix
+
+
+libSMESHimpl_la_LDFLAGS = \
+       ../SMESHDS/libSMESHDS.la \
+       ../Controls/libSMESHControls.la \
+       ../DriverDAT/libMeshDriverDAT.la \
+       ../DriverSTL/libMeshDriverSTL.la \
+       ../DriverMED/libMeshDriverMED.la \
+       ../DriverUNV/libMeshDriverUNV.la \
+       $(GEOM_LDFLAGS) -lNMTTools \
+       $(CAS_LDPATH) -lTKShHealing