Salome HOME
Merge from V6_main_20120808 08Aug12
[modules/smesh.git] / doc / salome / gui / SMESH / Makefile.am
index a93b57ccb0eaed84b96225b5f61b1c279c7b6111..cc3ddb25155e64ff5e38d01cbc7aa4b6c3a13495 100755 (executable)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  File   : Makefile.in
 #  Author : Vasily Rusyaev (Open Cascade NN)
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
-EXTRA_DIST += images input static
+EXTRA_DIST += images input static/footer.html static/doxygen.css
+
+guidocdir = $(docdir)/gui/SMESH
+guidoc_DATA = images/head.png
+
 
 usr_docs: doxyfile_py doxyfile 
-       echo "===========================================" ;            \
-       echo "Generating Python interface documentation";               \
-       echo "===========================================" ;            \
-       $(DOXYGEN) doxyfile_py ;                                        \
-       echo "===========================================" ;            \
-       echo "Replacing smeshDC by smesh" ;                             \
-       echo "===========================================" ;            \
-       files=`find smeshpy_doc -type f` ;                              \
-       for filen in $${files} ; do                                     \
-         sed -e "s/\<smeshDC\>/smesh/g" -e "s/smesh\.smesh/smesh/g"    \
-             -e "s/smesh::smesh/smesh/g" $${filen} > $${filen}_ ;      \
-         mv -f $${filen}_ $${filen} ;                                  \
-       done ;                                                          \
-       echo "===========================================" ;            \
-       echo "Generating GUI documentation" ;                           \
-       echo "===========================================" ;            \
-       $(DOXYGEN) doxyfile ;
+       echo "===========================================" ;                    \
+       echo "Replacing smeshDC by smesh" ;                                     \
+       echo "===========================================" ;                    \
+       awk '/^class Mesh:/ { mesh_found=1 } // { if (mesh_found) {print $$0; next} } /^ +(def|#)/ { match( $$0, /^ +/); print substr( $$0, 1+RLENGTH ); next } /^class smeshDC/ { next } //' \
+         $(top_srcdir)/src/SMESH_SWIG/smeshDC.py > ./smesh.py ;                \
+       echo "===========================================" ;                    \
+       echo "Generating Python interface documentation";                       \
+       echo "===========================================" ;                    \
+       $(DOXYGEN) doxyfile_py ;                                                \
+       echo "===========================================" ;                    \
+       echo "Generating GUI documentation" ;                                   \
+       echo "===========================================" ;                    \
+       $(DOXYGEN) doxyfile ;                                                   \
+       rm -f ./smesh.py
 
 docs: usr_docs
 
 clean-local:
-       @for filen in `find . -maxdepth 1` ; do                         \
+       @for filen in `find . -maxdepth 1` ; do                 \
          case $${filen} in                                     \
            ./Makefile | ./doxyfile | ./doxyfile_py ) ;;        \
-           . | .. ) ;;                                         \
+           . | .. | ./static ) ;;                              \
            *) echo "Removing $${filen}" ; rm -rf $${filen} ;;  \
          esac ;                                                \
        done ;
 
 install-data-local: usr_docs
        $(INSTALL) -d $(DESTDIR)$(docdir)/gui/SMESH
-       @for filen in `find . -maxdepth 1` ; do                                                         \
+       @for filen in `find . -maxdepth 1` ; do                                                 \
          case $${filen} in                                                                     \
            ./Makefile | ./doxyfile | ./doxyfile_py ) ;;                                        \
            ./doxyfile.bak | ./doxyfile_py.bak ) ;;                                             \
-           . | .. ) ;;                                                                         \
+           . | .. | ./static ) ;;                                                              \
            *) echo "Installing $${filen}" ; cp -rp $${filen} $(DESTDIR)$(docdir)/gui/SMESH ;;  \
          esac ;                                                                                \
-       done ;
+       done ;                                                                                  \
+       cp -rp $(srcdir)/images/head.png $(DESTDIR)$(docdir)/gui/SMESH/smeshpy_doc ;
 
 uninstall-local:
        rm -rf $(DESTDIR)$(docdir)/gui/SMESH