Salome HOME
Merge from BR_LIBBATCH_2_0
[tools/libbatch.git] / src / Core / CMakeLists.txt
index b866c2e1e858a326bdc3a4a5e95f112cda9671f2..0e5321400c56356beffafad9741ed9276661ec1e 100644 (file)
@@ -1,4 +1,4 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+#  Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 #  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
 #  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
 #  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
-SET(CLASS_LIST Core/Batch_APIInternalFailureException
-               Core/Batch_BatchManager_eClient
-               Core/Batch_BatchManager
-               Core/Batch_BatchManagerCatalog
-               Core/Batch_BoolType
-               Core/Batch_CharType
-               Core/Batch_CommunicationProtocol
-               Core/Batch_ConnexionFailureException
-               Core/Batch_Constants
-               Core/Batch_Couple
-               Core/Batch_CoupleType
-               Core/Batch_Date
-               Core/Batch_DateType
-               Core/Batch_EmulationException
-               Core/Batch_Environnement
-               Core/Batch_FactBatchManager_eClient
-               Core/Batch_FactBatchManager
-               Core/Batch_GenericException
-               Core/Batch_GenericType
-               Core/Batch_IntType
-               Core/Batch_InvalidArgumentException
-               Core/Batch_InvalidKeyException
-               Core/Batch_Job
-               Core/Batch_JobId
-               Core/Batch_JobInfo
-               Core/Batch_ListIsFullException
-               Core/Batch_LongType
-               Core/Batch_MapKey
-               Core/Batch_MpiImpl
-               Core/Batch_NotYetImplementedException
-               Core/Batch_Parametre
-               Core/Batch_RunTimeException
-               Core/Batch_StringType
-               Core/Batch_TypeMismatchException
-               Core/Batch_Versatile
+SET(CLASS_LIST Core/APIInternalFailureException
+               Core/BatchManager
+               Core/BatchManagerCatalog
+               Core/BoolType
+               Core/CommunicationProtocol
+               Core/Constants
+               Core/Couple
+               Core/CoupleType
+               Core/Environnement
+               Core/FactBatchManager
+               Core/GenericException
+               Core/GenericType
+               Core/InvalidArgumentException
+               Core/InvalidKeyException
+               Core/Job
+               Core/JobId
+               Core/JobInfo
+               Core/ListIsFullException
+               Core/LongType
+               Core/MpiImpl
+               Core/NotYetImplementedException
+               Core/ParameterTypeMap
+               Core/Parametre
+               Core/RunTimeException
+               Core/StringType
+               Core/TypeMismatchException
+               Core/Versatile
    )
 
+APPEND_CLASSES_TO_SRC_FILES(${CLASS_LIST}
+                            Core/Utils
+                            Core/Log)
+APPEND_CLASSES_TO_HDR_FILES(${CLASS_LIST})
+APPEND_CLASSES_TO_HDR_FILES(Core/Defines)
+
 IF (HAS_SH)
-    SET(CLASS_LIST ${CLASS_LIST}
-                   Core/Batch_CommunicationProtocolSH
-       )
+    APPEND_CLASSES_TO_SRC_FILES(Core/CommunicationProtocolSH)
 ENDIF (HAS_SH)
 
 IF (HAS_RSH)
-    SET(CLASS_LIST ${CLASS_LIST}
-                   Core/Batch_CommunicationProtocolRSH
-       )
+    APPEND_CLASSES_TO_SRC_FILES(Core/CommunicationProtocolRSH)
 ENDIF (HAS_RSH)
 
 IF (HAS_SSH)
-    SET(CLASS_LIST ${CLASS_LIST}
-                   Core/Batch_CommunicationProtocolSSH
-       )
+    APPEND_CLASSES_TO_SRC_FILES(Core/CommunicationProtocolSSH)
 ENDIF (HAS_SSH)
 
-APPEND_CLASSES_TO_SRC_FILES(${CLASS_LIST})
-APPEND_CLASSES_TO_HDR_FILES(${CLASS_LIST})
-APPEND_CLASSES_TO_HDR_FILES(Core/Batch_Defines)
 
 IF (TEST_ENABLED)
     add_subdirectory(Test)