Salome HOME
Porting to Paraview 5.8
[plugins/hexoticplugin.git] / src / GUI / CMakeLists.txt
old mode 100755 (executable)
new mode 100644 (file)
index 8febf77..53e2405
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2014  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2019  CEA/DEN, EDF R&D
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 
 ADD_SUBDIRECTORY(resources)
 
-INCLUDE(UseQt4Ext)
+INCLUDE(UseQtExt)
 
 # --- options ---
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${QT_INCLUDES}
-  ${CAS_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${PYTHON_INCLUDES}
   ${KERNEL_INCLUDE_DIRS}
   ${GUI_INCLUDE_DIRS}
   ${GEOM_INCLUDE_DIRS}
   ${SMESH_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
   ${OMNIORB_INCLUDE_DIR}
   ${CMAKE_CURRENT_BINARY_DIR}
   ${PROJECT_BINARY_DIR}/idl
   ${PROJECT_SOURCE_DIR}/src/HexoticPlugin
+  ${PROJECT_SOURCE_DIR}/src/GUI
 )
 
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
   ${QT_DEFINITIONS}
   ${OMNIORB_DEFINITIONS}
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
@@ -51,7 +51,8 @@ ADD_DEFINITIONS(
 SET(_link_LIBRARIES
   ${SMESH_SMESH}
   ${SMESH_StdMeshersGUI}
-  ${CAS_KERNEL}
+  ${SMESH_PluginUtils}
+  ${OpenCASCADE_FoundationClasses_LIBRARIES}
   ${GUI_suit}
   ${GUI_qtx}
   ${GUI_SalomeApp}
@@ -66,6 +67,7 @@ SET(_link_LIBRARIES
 SET(_moc_HEADERS
   HexoticPluginGUI_HypothesisCreator.h
   HexoticPluginGUI_Dlg.h
+  HexoticPluginGUI_TreeWidget.h
 )
 
 # header files / no moc processed
@@ -78,14 +80,17 @@ SET(HexoticPluginGUI_HEADERS ${_moc_HEADERS} ${_other_HEADERS})
 # --- sources ---
 
 # sources / moc wrappings
-QT4_WRAP_CPP(_moc_SOURCES ${_moc_HEADERS})
+QT_WRAP_MOC(_moc_SOURCES ${_moc_HEADERS})
 
 # sources / static
 SET(_other_SOURCES
   HexoticPluginGUI.cxx
   HexoticPluginGUI_StdWidget.cxx
+  HexoticPluginGUI_AdvWidget.cxx
   HexoticPluginGUI_SizeMapsWidget.cxx
+  HexoticPluginGUI_ViscousLayersWidget.cxx
   HexoticPluginGUI_HypothesisCreator.cxx
+  HexoticPluginGUI_TreeWidget.cxx
 )
 
 # --- resources ---
@@ -95,16 +100,19 @@ SET(_ts_RESOURCES
   HexoticPLUGIN_images.ts
   HexoticPLUGIN_msg_en.ts
   HexoticPLUGIN_msg_fr.ts
+  HexoticPLUGIN_msg_ja.ts
 ) 
 
 # resource files / to be processed by uic
 SET(_uic_files
   HexoticPluginGUI_StdWidget_QTD.ui
+  HexoticPluginGUI_AdvWidget_QTD.ui
   HexoticPluginGUI_SizeMapsWidget_QTD.ui
+  HexoticPluginGUI_ViscousLayersWidget_QTD.ui
 )
 
 # header files / uic wrappings
-QT4_WRAP_UI(_uic_HEADERS ${_uic_files})
+QT_WRAP_UIC(_uic_HEADERS ${_uic_files})
 
 # sources / to compile
 SET(HexoticPluginGUI_SOURCES ${_other_SOURCES} ${_moc_SOURCES} ${_uic_HEADERS})
@@ -117,4 +125,4 @@ INSTALL(TARGETS HexoticPluginGUI EXPORT ${PROJECT_NAME}TargetGroup DESTINATION $
 
 INSTALL(FILES ${HexoticPluginGUI_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})
 
-QT4_INSTALL_TS_RESOURCES("${_ts_RESOURCES}" "${SALOME_HexoticPLUGIN_INSTALL_RES_DATA}")
+QT_INSTALL_TS_RESOURCES("${_ts_RESOURCES}" "${SALOME_HexoticPLUGIN_INSTALL_RES_DATA}")