Salome HOME
Porting to Paraview 5.8
[plugins/hexoticplugin.git] / src / GUI / CMakeLists.txt
index 33c811b8a28affeb748dbbed5b6d8e9f141f3106..53e2405ab1bcf366229f25c7d81d31f3bb959514 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2016  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2019  CEA/DEN, EDF R&D
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -31,12 +31,12 @@ INCLUDE_DIRECTORIES(
   ${GUI_INCLUDE_DIRS}
   ${GEOM_INCLUDE_DIRS}
   ${SMESH_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
   ${OMNIORB_INCLUDE_DIR}
   ${CMAKE_CURRENT_BINARY_DIR}
   ${PROJECT_BINARY_DIR}/idl
   ${PROJECT_SOURCE_DIR}/src/HexoticPlugin
+  ${PROJECT_SOURCE_DIR}/src/GUI
 )
 
 # additional preprocessor / compiler flags
@@ -67,6 +67,7 @@ SET(_link_LIBRARIES
 SET(_moc_HEADERS
   HexoticPluginGUI_HypothesisCreator.h
   HexoticPluginGUI_Dlg.h
+  HexoticPluginGUI_TreeWidget.h
 )
 
 # header files / no moc processed
@@ -85,9 +86,11 @@ QT_WRAP_MOC(_moc_SOURCES ${_moc_HEADERS})
 SET(_other_SOURCES
   HexoticPluginGUI.cxx
   HexoticPluginGUI_StdWidget.cxx
+  HexoticPluginGUI_AdvWidget.cxx
   HexoticPluginGUI_SizeMapsWidget.cxx
   HexoticPluginGUI_ViscousLayersWidget.cxx
   HexoticPluginGUI_HypothesisCreator.cxx
+  HexoticPluginGUI_TreeWidget.cxx
 )
 
 # --- resources ---
@@ -103,6 +106,7 @@ SET(_ts_RESOURCES
 # resource files / to be processed by uic
 SET(_uic_files
   HexoticPluginGUI_StdWidget_QTD.ui
+  HexoticPluginGUI_AdvWidget_QTD.ui
   HexoticPluginGUI_SizeMapsWidget_QTD.ui
   HexoticPluginGUI_ViscousLayersWidget_QTD.ui
 )