Salome HOME
updated copyright message
[plugins/ghs3dprlplugin.git] / src / tepal2med / CMakeLists.txt
index f4bdd038c7252796a908d0d937b7a063ad2a5182..459a4090569c7e9520241a11beed2e0c481d81a4 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2023  CEA, EDF
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -17,7 +17,7 @@
 # See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
-INCLUDE(UseQt4Ext)
+INCLUDE(UseQtExt)
 
 # --- options ---
 # additional include directories
@@ -59,14 +59,13 @@ SET(tepal2med_HEADERS ${_moc_HEADERS} ${_other_HEADERS})
 # --- sources ---
 
 # sources / moc wrappings
-QT4_WRAP_CPP(_moc_SOURCES ${_moc_HEADERS})
+QT_WRAP_MOC(_moc_SOURCES ${_moc_HEADERS})
 
 # sources / static
 SET(_other_SOURCES
   ghs3dprl_mesh_wrap.cxx
   ghs3dprl_msg_parser.cxx
   dlg_ghs3dmain.cxx
-  tepal2med.cxx
 )
 
 # resource files / to be processed by uic
@@ -75,13 +74,16 @@ SET(_uic_files
 )
 
 # header files / uic wrappings
-QT4_WRAP_UI(_uic_HEADERS ${_uic_files})
+QT_WRAP_UIC(_uic_HEADERS ${_uic_files})
 
 # sources / to compile
-SET(tepal2med_SOURCES ${_other_SOURCES} ${_moc_SOURCES} ${_uic_HEADERS})
+SET(tepal2med_SOURCES tepal2med.cxx ${_other_SOURCES} ${_moc_SOURCES} ${_uic_HEADERS})
+SET(tetrahpc2med_SOURCES tetrahpc2med.cxx ${_other_SOURCES} ${_moc_SOURCES} ${_uic_HEADERS})
 
 # --- rules ---
 
 ADD_EXECUTABLE(tepal2med ${tepal2med_SOURCES})
+ADD_EXECUTABLE(tetrahpc2med ${tetrahpc2med_SOURCES})
 TARGET_LINK_LIBRARIES(tepal2med ${_link_LIBRARIES})
-INSTALL(TARGETS tepal2med EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
+TARGET_LINK_LIBRARIES(tetrahpc2med ${_link_LIBRARIES})
+INSTALL(TARGETS tepal2med tetrahpc2med EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})