Salome HOME
Merge from V6_5_BR 05/06/2012
[modules/smesh.git] / src / Tools / padder / meshjob / idl / Makefile.am
index 1f6ae9af2ca37a7439323d74ed5e513f9de33621..15bb1a87cb84740c1241f2bbd96c0a87d04a43b6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2011-2012  CEA/DEN, EDF R&D
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -31,6 +31,8 @@ IDL_FILES = MESHJOB.idl
 BUILT_SOURCES += SPADDERPluginTestSK.cc
 IDL_FILES += SPADDERPluginTest.idl
 
+IDL_FILES_PY=$(IDL_FILES:%.idl=%_idl.py)
+
 salomeidl_DATA = $(IDL_FILES) 
 
 lib_LTLIBRARIES = libSalomeIDLSPADDER.la
@@ -81,6 +83,13 @@ install-data-local: $(IDL_FILES)
        $(OMNIORB_IDL) $(IDLPYFLAGS) -C$(DESTDIR)$(salomepythondir) $$file ; \
        done
 
+# we want to remove only staff generated for IDL files and nothing more
 uninstall-local:
-       rm -rf $(DESTDIR)$(salomepythondir)/*
+       @for modulen in MESHJOB SPADDERPluginTest  ; do \
+         test -d $(DESTDIR)$(salomepythondir)/$${modulen} && echo "Removing $(DESTDIR)$(salomepythondir)/$${modulen}" && rm -rf $(DESTDIR)$(salomepythondir)/$${modulen} ; \
+         test -d $(DESTDIR)$(salomepythondir)/$${modulen}__POA && echo "Removing $(DESTDIR)$(salomepythondir)/$${modulen}__POA" && rm -rf $(DESTDIR)$(salomepythondir)/$${modulen}__POA ; \
+       done ; \
+       for filen in $(IDL_FILES_PY) ; do \
+         echo "Removing $(DESTDIR)$(salomepythondir)/$${filen}" && rm -f $(DESTDIR)$(salomepythondir)/$${filen}* ; \
+       done