Salome HOME
Zcracks plugin adaptation to new Zcracks tool
[modules/smesh.git] / src / Tools / ZCracksPlug / CMakeLists.txt
index 07cbf93b103f0c5bd7455f8bf9770315bbe4d2c3..288b9d7833ca77cc1836a1053f32ea43e6d75239 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  EDF R&D
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 # See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
+ADD_SUBDIRECTORY(casTests)
 
+INCLUDE(UsePyQt)
 
 # --- scripts ---
 
 # scripts / static
 SET(plugin_SCRIPTS
-   zcracks_plugin.py
+  __init__.py
+  ellipse.py
+  genereCrack.py
+  images_rc.py
+  main.py
+  output.py
+  rectangle.py
+  sphere.py
+  utilityFunctions.py
+  zcracks_plugin.py
+  Zset.py
 )
 
+SET(command_SCRIPTS
+  zcracksLaunch.py
+)
 
-# --- rules ---
+# --- resources ---
+
+# uic files / to be processed by pyuic
+SET(_pyuic_files
+  zcracks.ui
+)
+
+# scripts / pyuic wrappings
+PYQT_WRAP_UIC(_pyuic_SCRIPTS ${_pyuic_files})
 
-SALOME_INSTALL_SCRIPTS("${plugin_SCRIPTS}" ${SALOME_SMESH_INSTALL_PLUGINS})
+# --- rules ---
 
+SALOME_INSTALL_SCRIPTS("${plugin_SCRIPTS}" ${SALOME_INSTALL_PYTHON}/Zcracks)
+SALOME_INSTALL_SCRIPTS("${_pyuic_SCRIPTS}" ${SALOME_INSTALL_PYTHON}/Zcracks)
+SALOME_INSTALL_SCRIPTS("${command_SCRIPTS}" ${SALOME_INSTALL_BINS})