Salome HOME
022491: EDF 2249 SMESH: Integration of a small python library for quadrangle meshing
[modules/smesh.git] / src / Tools / Verima / CMakeLists.txt
index 81f98554adbc39e174bac8e310d988d4fe296526..a71fe299748990c0a49b51fc80eb8cd4a6a5025d 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D
+# Copyright (C) 2012-201 EDF R&D
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 #
 # See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+IF(SALOME_BUILD_DOC)
+  ADD_SUBDIRECTORY(Doc)
+ENDIF(SALOME_BUILD_DOC)
+ADD_SUBDIRECTORY(CreeDocuments)
+IF(SALOME_BUILD_GUI)
+  ADD_SUBDIRECTORY(Gui)
+ENDIF(SALOME_BUILD_GUI)
+ADD_SUBDIRECTORY(Scripts)
+ADD_SUBDIRECTORY(Stats)
+ADD_SUBDIRECTORY(Base)
 
-ADD_SUBDIRECTORY(Doc)
-#ADD_SUBDIRECTORY(CreeDocuments)
-#ADD_SUBDIRECTORY(Gui)
-#ADD_SUBDIRECTORY(Scripts)
-#ADD_SUBDIRECTORY(Stats)
-#ADD_SUBDIRECTORY(Base)
+# --- scripts ---
+
+# scripts / static
+SET(plugin_SCRIPTS
+  ajoutEnreg.py
+  changeVersion.py
+  compareVersions.py
+  createDatabase.py
+  lance.py
+  passeJobs.py
+  ) 
+
+# --- rules ---
+
+SALOME_INSTALL_SCRIPTS("${plugin_SCRIPTS}" ${SALOME_SMESH_INSTALL_PLUGINS})