Salome HOME
0022098: EDF 2036 SMESH: Create groups from none conected parts of a mesh
[modules/smesh.git] / src / SMESHUtils / Makefile.am
index 0e5f876248d593c837fd9e7eb6387ca4a2ac0209..414ab25ff3fd274d70cdd8a8c6c20cb1ff8a22ed 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -26,12 +26,16 @@ include $(top_srcdir)/adm_local/unix/make_common_starter.am
 salomeinclude_HEADERS = \
        SMESH_Block.hxx \
        SMESH_TypeDefs.hxx \
+       SMESH_Tree.hxx \
        SMESH_Octree.hxx \
+       SMESH_Quadtree.hxx \
        SMESH_OctreeNode.hxx \
        SMESH_Comment.hxx \
        SMESH_ComputeError.hxx \
        SMESH_File.hxx \
-       SMESH_Utils.hxx
+       SMESH_Utils.hxx \
+       SMESH_TryCatch.hxx \
+       SMESH_MeshAlgos.hxx
 
 # Libraries targets
 
@@ -39,9 +43,12 @@ lib_LTLIBRARIES = libSMESHUtils.la
 
 dist_libSMESHUtils_la_SOURCES = \
        SMESH_Block.cxx \
+       SMESH_Quadtree.cxx \
        SMESH_Octree.cxx \
        SMESH_OctreeNode.cxx \
-       SMESH_File.cxx
+       SMESH_TryCatch.cxx \
+       SMESH_File.cxx \
+       SMESH_MeshAlgos.cxx
 
 # additionnal information to compile and link file
 libSMESHUtils_la_CPPFLAGS = \