Salome HOME
54122: Bad quality prismatic mesh
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index c1322fb3a0183d082391e33ff1dec100a01530a2..c84715eed262da158df4cb9103f7668cfc0a999f 100644 (file)
@@ -44,6 +44,7 @@ SET(_link_LIBRARIES
   ${CAS_TKGeomBase}
   ${CAS_TKGeomAlgo}
   ${CAS_TKTopAlgo}
+  ${CAS_TKMesh}
   ${Boost_LIBRARIES}
   SMDS
 )
@@ -66,6 +67,7 @@ SET(SMESHUtils_HEADERS
   SMESH_MeshAlgos.hxx
   SMESH_MAT2d.hxx
   SMESH_ControlPnt.hxx
+  SMESH_Delaunay.hxx
 )
 
 # --- sources ---
@@ -82,7 +84,9 @@ SET(SMESHUtils_SOURCES
   SMESH_MAT2d.cxx
   SMESH_FreeBorders.cxx
   SMESH_ControlPnt.cxx
-)
+  SMESH_DeMerge.cxx
+  SMESH_Delaunay.cxx
+  )
 
 # --- rules ---