Salome HOME
54122: Bad quality prismatic mesh
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index 486454e74b45ac173f8cb1b8cdf5ab90b412e45c..c84715eed262da158df4cb9103f7668cfc0a999f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -43,6 +43,8 @@ SET(_link_LIBRARIES
   ${CAS_TKG3d}
   ${CAS_TKGeomBase}
   ${CAS_TKGeomAlgo}
+  ${CAS_TKTopAlgo}
+  ${CAS_TKMesh}
   ${Boost_LIBRARIES}
   SMDS
 )
@@ -63,6 +65,9 @@ SET(SMESHUtils_HEADERS
   SMESH_Utils.hxx
   SMESH_TryCatch.hxx
   SMESH_MeshAlgos.hxx
+  SMESH_MAT2d.hxx
+  SMESH_ControlPnt.hxx
+  SMESH_Delaunay.hxx
 )
 
 # --- sources ---
@@ -76,7 +81,12 @@ SET(SMESHUtils_SOURCES
   SMESH_TryCatch.cxx
   SMESH_File.cxx
   SMESH_MeshAlgos.cxx
-)
+  SMESH_MAT2d.cxx
+  SMESH_FreeBorders.cxx
+  SMESH_ControlPnt.cxx
+  SMESH_DeMerge.cxx
+  SMESH_Delaunay.cxx
+  )
 
 # --- rules ---