Salome HOME
WIN32 compilation of the SMESH module:
[modules/smesh.git] / src / SMESHGUI / CMakeLists.txt
index 725c34ae2adbf4db92e55adcb86f034dedcb94ea..a3673cf3f672dee9fb102664afc9306455dfea5e 100644 (file)
@@ -56,6 +56,11 @@ ADD_DEFINITIONS(
   ${OMNIORB_DEFINITIONS}
 )
 
+# To avoid GetObject macro definition on WIN32
+IF(WIN32)
+  ADD_DEFINITIONS(-DNOGDI)
+ENDIF(WIN32)
+
 # libraries to link to
 SET(_link_LIBRARIES
   ${CAS_TKV3d}