Salome HOME
Merge from V6_main_20120808 08Aug12
[modules/smesh.git] / src / SMESHDS / Makefile.am
index b9c3673f33a592578403e2b44fd49bb7c17b0066..745ccca8f724a4e4ad77b47367355fc76473addc 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  SMESH SMESHDS : management of mesh data and SMESH document
 #  File   : Makefile.in
 #  Author : Patrick GOLDBRONN (CEA)
@@ -39,8 +37,10 @@ salomeinclude_HEADERS = \
        SMESHDS_GroupBase.hxx \
        SMESHDS_Group.hxx \
        SMESHDS_GroupOnGeom.hxx \
+       SMESHDS_GroupOnFilter.hxx \
        SMESH_SMESHDS.hxx \
-       SMESHDS_DataMapOfShape.hxx
+       SMESHDS_DataMapOfShape.hxx \
+       SMESH_Controls.hxx
 
 # Libraries targets
 lib_LTLIBRARIES = libSMESHDS.la
@@ -54,12 +54,14 @@ dist_libSMESHDS_la_SOURCES = \
        SMESHDS_Mesh.cxx \
        SMESHDS_GroupBase.cxx \
        SMESHDS_Group.cxx \
-       SMESHDS_GroupOnGeom.cxx
+       SMESHDS_GroupOnGeom.cxx \
+       SMESHDS_GroupOnFilter.cxx
 
 # additionnal information to compil and link file
 libSMESHDS_la_CPPFLAGS = \
        $(KERNEL_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
        -I$(srcdir)/../SMDS