Salome HOME
correct previous integration (Porting to Python 2.6)
[modules/smesh.git] / src / OBJECT / Makefile.am
index 23723718d23fb4157eb7ff6ddc2271f016b38b8a..9a04613b394b6663d8e378c79d02e9ac699d8ffd 100644 (file)
@@ -1,39 +1,42 @@
-#  SMESH OBJECT : interactive object for SMESH visualization
+#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+#
+#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
+#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
 #
-#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#  This library is free software; you can redistribute it and/or
+#  modify it under the terms of the GNU Lesser General Public
+#  License as published by the Free Software Foundation; either
+#  version 2.1 of the License.
 #
+#  This library is distributed in the hope that it will be useful,
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+#  Lesser General Public License for more details.
 #
+#  You should have received a copy of the GNU Lesser General Public
+#  License along with this library; if not, write to the Free Software
+#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#
+#  SMESH OBJECT : interactive object for SMESH visualization
 #  File   : Makefile.in
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-
+#
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
        SMESH_Actor.h \
-        SMESH_Object.h \
+       SMESH_Object.h \
        SMESH_ObjectDef.h \
-       SMESH_ActorUtils.h
-
+       SMESH_ActorUtils.h \
+       SMESH_ActorDef.h \
+       SMESH_DeviceActor.h \
+       SMESH_PreviewActorsCollection.h \
+       SMESH_ExtractGeometry.h \
+       SMESH_FaceOrientationFilter.h
 
 # Libraries targets
 
@@ -42,10 +45,13 @@ dist_libSMESHObject_la_SOURCES = \
        SMESH_Object.cxx \
        SMESH_DeviceActor.cxx \
        SMESH_Actor.cxx \
+       SMESH_PreviewActorsCollection.cxx \
        SMESH_ExtractGeometry.cxx \
-       SMESH_ActorUtils.cxx
+       SMESH_ActorUtils.cxx \
+       SMESH_FaceOrientationFilter.cxx
 
 libSMESHObject_la_CPPFLAGS = \
+        $(QT_INCLUDES) \
         $(KERNEL_CXXFLAGS) \
         $(GUI_CXXFLAGS) \
        $(MED_CXXFLAGS) \
@@ -53,6 +59,7 @@ libSMESHObject_la_CPPFLAGS = \
        $(CAS_CPPFLAGS) \
         $(VTK_INCLUDES) \
        $(CORBA_INCLUDES) \
+       $(CORBA_CXXFLAGS) \
         $(BOOST_CPPFLAGS) \
         $(QT_INCLUDES) \
        -I$(srcdir)/../Controls \
@@ -62,13 +69,13 @@ libSMESHObject_la_CPPFLAGS = \
        -I$(srcdir)/../DriverMED \
        -I$(srcdir)/../SMESH \
        -I$(srcdir)/../SMESHClient \
-       -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
+       -I$(top_builddir)/idl
 
 libSMESHObject_la_LDFLAGS  = \
         ../SMESHClient/libSMESHClient.la \
         ../SMDS/libSMDS.la \
         ../Controls/libSMESHControls.la \
-        $(GUI_LDFLAGS) -lSalomeApp lSalomeObject \
+        $(GUI_LDFLAGS) -lSalomeApp -lSalomeObject -lSVTK -lVTKViewer -lqtx -lsuit \
+       $(GEOM_LDFLAGS) -lGEOMObject \
        $(CAS_KERNEL) \
-        $(VTK_LIBS)
+        $(VTK_LIBS) $(QT_MT_LIBS)