Salome HOME
23514: EDF 16031 - SMESH freezes
[modules/smesh.git] / src / DriverMED / CMakeLists.txt
index 8d4d58a0585ca11a9f987163d8c7f519ebda067f..c392d12ac5b53e2ea9b5fd95190b54610336b6df 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -67,6 +67,7 @@ SET(MeshDriverMED_HEADERS
   DriverMED_R_SMESHDS_Mesh.h
   DriverMED_W_SMESHDS_Mesh.h
   DriverMED_Family.h
+  DriverMED_W_Field.h
   SMESH_DriverMED.hxx
 )
 
@@ -77,11 +78,7 @@ SET(MeshDriverMED_SOURCES
   DriverMED_R_SMESHDS_Mesh.cxx
   DriverMED_W_SMESHDS_Mesh.cxx
   DriverMED_Family.cxx
-)
-
-# bin programs
-SET(MeshDriverMED_bin_SOURCES
-  MED_Test.cxx
+  DriverMED_W_Field.cxx
 )
 
 # --- rules ---
@@ -90,9 +87,4 @@ ADD_LIBRARY(MeshDriverMED ${MeshDriverMED_SOURCES})
 TARGET_LINK_LIBRARIES(MeshDriverMED ${_link_LIBRARIES} )
 INSTALL(TARGETS MeshDriverMED EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
-ADD_EXECUTABLE(MED_Test_bin ${MeshDriverMED_bin_SOURCES})
-TARGET_LINK_LIBRARIES(MED_Test_bin ${_link_LIBRARIES_bin} MeshDriverMED)
-SET_TARGET_PROPERTIES(MED_Test_bin PROPERTIES OUTPUT_NAME "MED_Test")
-INSTALL(TARGETS MED_Test_bin EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
-
 INSTALL(FILES ${MeshDriverMED_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})