Salome HOME
Merge from V6_main_20120808 08Aug12
[modules/smesh.git] / src / DriverDAT / Makefile.am
index 2a9973796d68a1966fe53aa48c9069f94f4aeda7..338bc1d17e5bcdc0c75cad22901a109fc9f3071b 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  SMESH DriverDAT : driver to read and write 'dat' files
 #  File   : Makefile.in
 #  Author : Marc Tajchman (CEA)
@@ -31,11 +29,7 @@ include $(top_srcdir)/adm_local/unix/make_common_starter.am
 # header files 
 salomeinclude_HEADERS = \
        DriverDAT_R_SMDS_Mesh.h \
-       DriverDAT_R_SMESHDS_Mesh.h \
-       DriverDAT_R_SMESHDS_Document.h \
        DriverDAT_W_SMDS_Mesh.h \
-       DriverDAT_W_SMESHDS_Mesh.h \
-       DriverDAT_W_SMESHDS_Document.h \
        SMESH_DriverDAT.hxx
 
 # Libraries targets
@@ -43,11 +37,7 @@ lib_LTLIBRARIES = libMeshDriverDAT.la
 
 dist_libMeshDriverDAT_la_SOURCES = \
        DriverDAT_R_SMDS_Mesh.cxx \
-       DriverDAT_R_SMESHDS_Mesh.cxx \
-       DriverDAT_R_SMESHDS_Document.cxx \
-       DriverDAT_W_SMDS_Mesh.cxx \
-       DriverDAT_W_SMESHDS_Mesh.cxx \
-       DriverDAT_W_SMESHDS_Document.cxx
+       DriverDAT_W_SMDS_Mesh.cxx
 
 # Executables targets
 bin_PROGRAMS = DAT_Test
@@ -58,6 +48,7 @@ dist_DAT_Test_SOURCES = \
 libMeshDriverDAT_la_CPPFLAGS = \
        $(KERNEL_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../SMDS \
@@ -65,6 +56,7 @@ libMeshDriverDAT_la_CPPFLAGS = \
 
 libMeshDriverDAT_la_LDFLAGS  = \
        ../Driver/libMeshDriver.la \
+       $(KERNEL_LDFLAGS) -lSALOMEBasics \
        $(CAS_KERNEL)
 
 DAT_Test_CPPFLAGS = \