Salome HOME
Fix linkage problem
[modules/smesh.git] / src / Controls / Makefile.am
index 0dd516e946bdda88f5cf355c50054aab1f0674b0..bf1c1d9021f2fbf0f7982bcdd5d65edd4f48f5eb 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  File   : Makefile.in
 #  Author : Patrick GOLDBRONN (CEA)
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
@@ -28,7 +26,6 @@ include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
-       SMESH_Controls.hxx \
        SMESH_ControlsDef.hxx
 
 # Libraries targets
@@ -45,15 +42,20 @@ dist_SMESHControls_SOURCES = \
 # additionnal information to compil and link file
 libSMESHControls_la_CPPFLAGS = \
        $(CAS_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
        $(KERNEL_CXXFLAGS) \
        -I$(srcdir)/../SMDS \
-       -I$(srcdir)/../SMESHDS
+       -I$(srcdir)/../SMESHDS \
+       -I$(srcdir)/../SMESHUtils
 
 libSMESHControls_la_LDFLAGS = \
        ../SMDS/libSMDS.la \
        ../SMESHDS/libSMESHDS.la \
-       $(CAS_LDPATH) -lTKernel -lTKBRep -lTKG3d
+       ../SMESHUtils/libSMESHUtils.la \
+       $(CAS_LDPATH) -lTKernel -lTKBRep -lTKG3d -lTKTopAlgo -lTKGeomBase -lTKGeomAlgo \
+       $(VTK_LIBS) \
+       $(KERNEL_LDFLAGS) -lOpUtil -lSALOMELocalTrace -lSALOMEBasics
 
 SMESHControls_CPPFLAGS = \
        $(libSMESHControls_la_CPPFLAGS)
@@ -63,6 +65,5 @@ SMESHControls_LDADD = \
        ../SMDS/libSMDS.la \
        ../SMESHDS/libSMESHDS.la \
        libSMESHControls.la \
-       $(KERNEL_LDFLAGS) -lOpUtil -lSALOMELocalTrace -lSALOMEBasics \
-       $(GEOM_LDFLAGS) -lGEOMAlgo \
+       $(KERNEL_LDFLAGS) -lOpUtil -lSALOMELocalTrace -lSALOMEBasics -lSalomeIDLKernel \
        $(CAS_LDPATH) -lTKernel -lTKBRep -lTKG3d