Salome HOME
22806: EDF SMESH: Regression: Prism_3D error
[modules/smesh.git] / src / CMakeLists.txt
index 9ef95077aa2caa894105ff022c538e383babca24..257de2054d160fb9b4b140c6e6fbe95106b20276 100755 (executable)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2014  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -55,13 +55,16 @@ SET(SUBDIRS_COMMON
   SMESH_I
   SMESHClient
   SMESH_SWIG
-  MEFISTO2
   StdMeshers
   StdMeshers_I
   SMESH_PY
   Tools
 )
 
+IF(SALOME_SMESH_ENABLE_MEFISTO)
+  SET(SUBDIRS_MEFISTO2 MEFISTO2)
+ENDIF(SALOME_SMESH_ENABLE_MEFISTO)
+
 ##
 # CGNS
 ##
@@ -86,6 +89,7 @@ ENDIF(SALOME_BUILD_GUI)
 
 SET(SUBDIRS
   ${SUBDIRS_COMMON}
+  ${SUBDIRS_MEFISTO2}
   ${SUBDIRS_CGNS}
   ${SUBDIRS_GUI}
 )