Salome HOME
0022108: EDF 2547 SMESH: Duplicate elements only
[modules/smesh.git] / resources / Makefile.am
index 2ebd83edff16cbd8faf46130d2563fa68c137103..fa9b24036d6e47a27d149392ab5ec48f70979b0d 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 # -* Makefile *- 
 # Author : Patrick GOLDBRONN (CEA)
 # Date : 28/06/2001
@@ -38,6 +36,8 @@ dist_salomeres_DATA = \
        mesh_area.png \
        mesh_aspect.png \
        mesh_aspect_3d.png \
+       mesh_biquad_quadrangle.png \
+       mesh_biquad_triangle.png \
        mesh_clear.png \
        mesh_compute.png \
        mesh_diagonal.png \
@@ -51,18 +51,27 @@ dist_salomeres_DATA = \
        mesh_info.png \
        advanced_mesh_info.png \
        standard_mesh_info.png \
+       mesh_elem_info.png \
+       mesh_equal_edge.png \
+       mesh_equal_face.png \
+       mesh_equal_node.png \
+       mesh_equal_volume.png \
        mesh_whatis.png \
        mesh_init.png \
        mesh_length.png \
        mesh_length_2d.png \
+       mesh_find_elem_by_point.png \
        mesh_free_edges.png \
        mesh_free_edges_2d.png \
        mesh_free_nodes.png \
+       mesh_max_element_length_2d.png \
+       mesh_max_element_length_3d.png \
        mesh_multi_edges.png \
        mesh_multi_edges_2d.png \
        mesh_line_n.png \
        mesh_line.png \
        mesh_move_node.png \
+       mesh_octahedron.png \
        mesh_orientation.png \
        mesh.png \
        mesh_polygon.png \
@@ -71,8 +80,14 @@ dist_salomeres_DATA = \
        mesh_pyramid.png \
        mesh_quad_n.png \
        mesh_quad.png \
+       mesh_quadrangle_quadpref.png \
+       mesh_quadrangle_quadpref_reversed.png \
+       mesh_quadrangle_reduced.png \
+       mesh_quadrangle_standard.png \
+       mesh_quadrangle_triapref.png \
        mesh_rem_element.png \
        mesh_rem_node.png \
+       mesh_rem_orphan_nodes.png \
        mesh_shading.png \
        mesh_shrink.png \
        mesh_skew.png \
@@ -81,6 +96,7 @@ dist_salomeres_DATA = \
        mesh_tree_algo_hexa.png \
        mesh_tree_algo_mefisto.png \
        mesh_tree_algo.png \
+       mesh_tree_algo_0D.png \
        mesh_tree_algo_quad.png \
        mesh_tree_algo_regular.png \
        mesh_tree_algo_tetra.png \
@@ -93,16 +109,24 @@ dist_salomeres_DATA = \
        mesh_tree_importedmesh.png \
        mesh_tree_mesh_warn.png \
        mesh_triangle_n.png \
+       mesh_triquad_hexahedron.png \
        mesh_triangle.png \
        mesh_update.png \
        mesh_vertex_n.png \
        mesh_vertex.png \
+       mesh_0D_elem.png \
+       mesh_0D_on_all_nodes.png \
        mesh_volume_3d.png \
+       bare_border_volume.png \
+       bare_border_face.png \
+       over_constrained_volume.png \
+       over_constrained_face.png \
        mesh_wireframe.png \
        mesh_points.png \
        mesh_wrap.png \
        mesh_group.png \
        mesh_tree_group.png \
+       mesh_tree_group_on_filter.png \
        mesh_edit_group.png \
        mesh_make_group.png \
        mesh_groups_from_gemetry.png \
@@ -134,8 +158,8 @@ dist_salomeres_DATA = \
        mesh_merge_elements.png \
        select1.png \
        StdMeshers.xml \
-       SalomeApp.xml \
        mesh_pattern.png \
+       mesh_pentahedron.png \
        pattern_sample_2d.png \
        pattern_sample_3D.png \
        mesh_add.png \
@@ -150,6 +174,9 @@ dist_salomeres_DATA = \
        mesh_conv_to_quad.png \
        mesh_tree_hypo_layers_distribution.png \
        mesh_tree_algo_radial_prism.png \
+       mesh_tree_algo_radial_quadrangle_1D2D.png \
+       mesh_tree_algo_existing_2D.png \
+       mesh_tree_algo_prism.png \
        mesh_tree_algo_projection_2d.png \
        mesh_hypo_source_edge.png \
        mesh_hypo_source_3d.png \
@@ -161,11 +188,26 @@ dist_salomeres_DATA = \
        mesh_tree_hypo_projection_3d.png \
        mesh_tree_hypo_projection_2d.png \
        mesh_build_compound.png \
+       copy_mesh.png \
        mesh_node_to_point.png \
        mesh_tree_mesh_partial.png \
        mesh_extractGroup.png \
        mesh_precompute.png \
-        mesh_free_faces.png
+       mesh_2d_from_3d.png \
+        mesh_free_faces.png \
+        scale.png \
+        scale_along_axes.png \
+       split_into_tetra.png \
+       mesh_duplicate_nodes.png \
+       mesh_duplicate_nodes_with_elem.png \
+       mesh_duplicate_elem_only.png \
+       mesh_bounding_box.png \
+       mesh_hypo_viscous_layers.png \
+       mesh_tree_hypo_viscous_layers.png \
+       mesh_min_dist.png \
+       reorient_faces_point.png \
+       reorient_faces_face.png \
+       mesh_ball.png
 
 # VSR: little trick to avoid putting if SMESHCatalog.xml to the distribution archive
-nodist_salomeres_SCRIPTS = SMESHCatalog.xml
+nodist_salomeres_SCRIPTS = SMESHCatalog.xml SalomeApp.xml