Salome HOME
23404: EDF 14011 - Problem with Quadrangle (Medial Axis projection) algorithm
[modules/smesh.git] / resources / CMakeLists.txt
index 6b6cd1d3ce6b093b09c1da533d5d1ec356b200ba..b7208534e303d6da8d31724bfde8b717ae2e0e12 100755 (executable)
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
 # CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
@@ -6,7 +6,7 @@
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -34,8 +34,12 @@ SET(SMESH_RESOURCES_FILES
   mesh_aspect_3d.png
   mesh_biquad_quadrangle.png
   mesh_biquad_triangle.png
+  mesh_choose.png
+  mesh_choose_all.png
   mesh_clear.png
   mesh_compute.png
+  mesh_evaluate.png
+  mesh_order.png
   mesh_diagonal.png
   mesh_edit.png
   mesh_hexa.png
@@ -44,6 +48,8 @@ SET(SMESH_RESOURCES_FILES
   mesh_hypo_segment.png
   mesh_hypo_volume.png
   mesh_hypo_edit.png
+  mesh_plus.png
+  mesh_minus.png
   mesh_info.png
   advanced_mesh_info.png
   standard_mesh_info.png
@@ -67,6 +73,7 @@ SET(SMESH_RESOURCES_FILES
   mesh_line_n.png
   mesh_line.png
   mesh_move_node.png
+  mesh_move_without_node.png
   mesh_octahedron.png
   mesh_orientation.png
   mesh.png
@@ -91,6 +98,7 @@ SET(SMESH_RESOURCES_FILES
   mesh_tetra.png
   mesh_tree_algo_hexa.png
   mesh_tree_algo_mefisto.png
+  mesh_tree_algo_polygon.png
   mesh_tree_algo.png
   mesh_tree_algo_0D.png
   mesh_tree_algo_quad.png
@@ -154,7 +162,6 @@ SET(SMESH_RESOURCES_FILES
   mesh_merge_elements.png
   select1.png
   open.png
-  StdMeshers.xml
   mesh_pattern.png
   mesh_pentahedron.png
   pattern_sample_2d.png
@@ -164,6 +171,7 @@ SET(SMESH_RESOURCES_FILES
   mesh_quad_edge.png
   mesh_quad_triangle.png
   mesh_quad_quadrangle.png
+  mesh_quad_polygon.png
   mesh_quad_tetrahedron.png
   mesh_quad_pyramid.png
   mesh_quad_pentahedron.png
@@ -184,6 +192,7 @@ SET(SMESH_RESOURCES_FILES
   mesh_tree_hypo_source_3d_shape.png
   mesh_tree_hypo_projection_3d.png
   mesh_tree_hypo_projection_2d.png
+  mesh_tree_hypo_quadratic.png
   mesh_build_compound.png
   copy_mesh.png
   mesh_node_to_point.png
@@ -195,23 +204,30 @@ SET(SMESH_RESOURCES_FILES
   scale.png
   scale_along_axes.png
   split_into_tetra.png
+  split_biquad.png
   mesh_duplicate_nodes.png
   mesh_duplicate_nodes_with_elem.png
   mesh_duplicate_elem_only.png
+  mesh_duplicate_group_boundary.png
   mesh_bounding_box.png
   mesh_hypo_viscous_layers.png
   mesh_tree_hypo_viscous_layers.png
   mesh_min_dist.png
   reorient_faces_point.png
   reorient_faces_face.png
+  reorient_faces_volume.png
   mesh_ball.png
   mesh_measure_basic_props.png
   mesh_measure_length.png
   mesh_measure_area.png
   mesh_measure_volume.png
+  mesh_extmeth_node_offset.png
+  mesh_extmeth_surf_offset_smooth.png
+  mesh_extmeth_face_offset.png
 )
 
 INSTALL(FILES ${SMESH_RESOURCES_FILES} DESTINATION ${SALOME_SMESH_INSTALL_RES_DATA})
 
 SALOME_CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/SalomeApp.xml.in ${CMAKE_CURRENT_BINARY_DIR}/SalomeApp.xml INSTALL ${SALOME_SMESH_INSTALL_RES_DATA})
+SALOME_CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/StdMeshers.xml.in ${CMAKE_CURRENT_BINARY_DIR}/StdMeshers.xml INSTALL ${SALOME_SMESH_INSTALL_RES_DATA})
 SALOME_CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/SMESHCatalog.xml.in ${CMAKE_CURRENT_BINARY_DIR}/SMESHCatalog.xml INSTALL ${SALOME_SMESH_INSTALL_RES_DATA})