Salome HOME
0022108: EDF 2547 SMESH: Duplicate elements only
[modules/smesh.git] / doc / salome / gui / SMESH / Makefile.am
index f142af100d780f5a431859f23c452be100ee0238..351520331059098f21ca748e1132bdb2478e233c 100755 (executable)
@@ -24,7 +24,7 @@
 #
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
-EXTRA_DIST += images input static/footer.html static/doxygen.css
+EXTRA_DIST += images input static/footer.html static/salome_extra.css
 
 dist_salomescript_PYTHON = collect_mesh_methods.py
 
@@ -75,4 +75,12 @@ install-data-local: usr_docs
        cp -rp $(srcdir)/images/head.png $(DESTDIR)$(docdir)/gui/SMESH/smeshpy_doc ;
 
 uninstall-local:
-       rm -rf $(DESTDIR)$(docdir)/gui/SMESH
+       @test -d $(DESTDIR)$(guidocdir) && chmod -R +w $(DESTDIR)$(guidocdir) ; \
+       for filen in `find $(DESTDIR)$(guidocdir) -mindepth 1 -maxdepth 1` dummy ; do \
+         case $${filen} in \
+           dummy ) ;; \
+           $(DESTDIR)$(guidocdir)/yams ) ;; \
+           $(DESTDIR)$(guidocdir)/head.png ) ;; \
+           * ) echo "removing $${filen}" && rm -rf $${filen} ;; \
+         esac ; \
+       done