Salome HOME
Updated copyright comment
[modules/med.git] / src / MEDCalc / cmp / CMakeLists.txt
index 22657a8ea12336aa7305166de93ed13293226c65..34dec257624a32a1807cff972acdd4e99d8d5120 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2016  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2024  CEA, EDF
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -39,22 +39,34 @@ SET(COMMON_SOURCES
   MEDPresentationManager_i.cxx
   MEDPresentation.cxx
   # presentations
+  MEDPresentationMeshView.cxx
   MEDPresentationScalarMap.cxx
-#  MEDPresentationContour.cxx
-#  MEDPresentationVectorField.cxx
-#  MEDPresentationSlices.cxx
-#  MEDPresentationDeflectionShape.cxx
-#  MEDPresentationPointSprite.cxx
+  MEDPresentationContour.cxx
+  MEDPresentationVectorField.cxx
+  MEDPresentationSlices.cxx
+  MEDPresentationPointSprite.cxx
+  MEDPresentationPlot3D.cxx
+  MEDPresentationDeflectionShape.cxx
+  MEDPresentationStreamLines.cxx
+  MEDPresentationCutSegment.cxx
+  MEDFactory_i.cxx
+  MEDFactory_No_Session_i.cxx
+  MEDFactory_Session_i.cxx
+
 )
 
-SET(MEDFactoryEngine_SOURCES
+SET(MEDEngineCommon_SOURCES
   ${COMMON_SOURCES}
-  MEDFactory_i.cxx
+)
+
+SET(MEDFactoryEngine_SOURCES
+    _MEDFactory_Session_i.cxx
 )
 
 SET(MEDEngine_SOURCES
-  ${COMMON_SOURCES}
   MED.cxx
+  MED_Session.cxx
+  MED_No_Session.cxx
 )
 
 SET(COMMON_LIBS
@@ -75,17 +87,22 @@ IF(WIN32)
   SET(COMMON_FLAGS "${COMMON_FLAGS} -DNOMINMAX")
 ENDIF(WIN32)
 
+ADD_LIBRARY(MEDEngineCommon SHARED ${MEDEngineCommon_SOURCES})
+SET_TARGET_PROPERTIES(MEDEngineCommon PROPERTIES COMPILE_FLAGS "${COMMON_FLAGS}")
+TARGET_LINK_LIBRARIES(MEDEngineCommon ${COMMON_LIBS})
+
 ADD_LIBRARY(MEDFactoryEngine SHARED ${MEDFactoryEngine_SOURCES})
 SET_TARGET_PROPERTIES(MEDFactoryEngine PROPERTIES COMPILE_FLAGS "${COMMON_FLAGS}")
-TARGET_LINK_LIBRARIES(MEDFactoryEngine ${COMMON_LIBS})
+TARGET_LINK_LIBRARIES(MEDFactoryEngine ${COMMON_LIBS} MEDEngineCommon)
 
-ADD_LIBRARY(MEDEngine SHARED ${MEDEngine_SOURCES})
-SET_TARGET_PROPERTIES(MEDEngine PROPERTIES COMPILE_FLAGS "${COMMON_FLAGS}")
-TARGET_LINK_LIBRARIES(MEDEngine ${COMMON_LIBS})
+ADD_LIBRARY(FIELDSEngine SHARED ${MEDEngine_SOURCES})
+SET_TARGET_PROPERTIES(FIELDSEngine PROPERTIES COMPILE_FLAGS "${COMMON_FLAGS}")
+TARGET_LINK_LIBRARIES(FIELDSEngine ${COMMON_LIBS} MEDEngineCommon)
 
 #INSTALL(TARGETS MEDFactoryEngine DESTINATION ${SALOME_INSTALL_LIBS})
+INSTALL(TARGETS MEDEngineCommon EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 INSTALL(TARGETS MEDFactoryEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
-INSTALL(TARGETS MEDEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
+INSTALL(TARGETS FIELDSEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
 FILE(GLOB MEDCALC_HEADERS_HXX "${CMAKE_CURRENT_SOURCE_DIR}/*.hxx")
 INSTALL(FILES ${MEDCALC_HEADERS_HXX} DESTINATION ${SALOME_INSTALL_HEADERS})