Salome HOME
Updated copyright comment
[modules/med.git] / src / MEDCalc / cmp / CMakeLists.txt
index 04baec0b760ef5616cf6907bc60cd9b8d6bad974..34dec257624a32a1807cff972acdd4e99d8d5120 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2016  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2024  CEA, EDF
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -45,7 +45,14 @@ SET(COMMON_SOURCES
   MEDPresentationVectorField.cxx
   MEDPresentationSlices.cxx
   MEDPresentationPointSprite.cxx
-  MEDPresentationDeflectionShape.cxx  
+  MEDPresentationPlot3D.cxx
+  MEDPresentationDeflectionShape.cxx
+  MEDPresentationStreamLines.cxx
+  MEDPresentationCutSegment.cxx
+  MEDFactory_i.cxx
+  MEDFactory_No_Session_i.cxx
+  MEDFactory_Session_i.cxx
+
 )
 
 SET(MEDEngineCommon_SOURCES
@@ -53,11 +60,13 @@ SET(MEDEngineCommon_SOURCES
 )
 
 SET(MEDFactoryEngine_SOURCES
-  MEDFactory_i.cxx
+    _MEDFactory_Session_i.cxx
 )
 
 SET(MEDEngine_SOURCES
   MED.cxx
+  MED_Session.cxx
+  MED_No_Session.cxx
 )
 
 SET(COMMON_LIBS
@@ -86,14 +95,14 @@ ADD_LIBRARY(MEDFactoryEngine SHARED ${MEDFactoryEngine_SOURCES})
 SET_TARGET_PROPERTIES(MEDFactoryEngine PROPERTIES COMPILE_FLAGS "${COMMON_FLAGS}")
 TARGET_LINK_LIBRARIES(MEDFactoryEngine ${COMMON_LIBS} MEDEngineCommon)
 
-ADD_LIBRARY(MEDEngine SHARED ${MEDEngine_SOURCES})
-SET_TARGET_PROPERTIES(MEDEngine PROPERTIES COMPILE_FLAGS "${COMMON_FLAGS}")
-TARGET_LINK_LIBRARIES(MEDEngine ${COMMON_LIBS} MEDEngineCommon)
+ADD_LIBRARY(FIELDSEngine SHARED ${MEDEngine_SOURCES})
+SET_TARGET_PROPERTIES(FIELDSEngine PROPERTIES COMPILE_FLAGS "${COMMON_FLAGS}")
+TARGET_LINK_LIBRARIES(FIELDSEngine ${COMMON_LIBS} MEDEngineCommon)
 
 #INSTALL(TARGETS MEDFactoryEngine DESTINATION ${SALOME_INSTALL_LIBS})
 INSTALL(TARGETS MEDEngineCommon EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 INSTALL(TARGETS MEDFactoryEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
-INSTALL(TARGETS MEDEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
+INSTALL(TARGETS FIELDSEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
 FILE(GLOB MEDCALC_HEADERS_HXX "${CMAKE_CURRENT_SOURCE_DIR}/*.hxx")
 INSTALL(FILES ${MEDCALC_HEADERS_HXX} DESTINATION ${SALOME_INSTALL_HEADERS})