Salome HOME
updated copyright message
[modules/med.git] / idl / CMakeLists.txt
index 8d3abc7cca82e712aad252dc8386f6c7040beb61..e153b639c0cd74900d69f0c629b5636c0b515ee0 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2023  CEA, EDF
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -22,17 +22,19 @@ INCLUDE(UseOmniORB)
 
 INCLUDE_DIRECTORIES(
   ${OMNIORB_INCLUDE_DIR} ${OMNIORB_INCLUDE_DIRS}
-  ${KERNEL_INCLUDE_DIRS}
   ${CMAKE_CURRENT_BINARY_DIR}
 )
 
 SET(SalomeIDLMED_IDLSOURCES
+  MED_Gen.idl
+  MEDCommandsHistoryManager.idl
   MEDCouplingCorbaServant.idl
   ParaMEDCouplingCorbaServant.idl
   MEDDataManager.idl
   MEDCalculator.idl
   MEDEventListener.idl
-  MEDOPFactory.idl
+  MEDPresentationManager.idl
+  MEDFactory.idl
 )
 
 IF(SALOME_USE_MPI)