Salome HOME
Fix detected error into test1.py since agy/arch2 branch integration
[modules/homard.git] / src / HOMARD_I / CMakeLists.txt
index 1d02926cb54adae48e3838ec65800acc0d99053e..e7d84a388940c9ce016de823fa9b4633718f14bc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2014  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2020  CEA/DEN, EDF R&D
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -29,6 +29,7 @@ INCLUDE_DIRECTORIES(
   ${PROJECT_BINARY_DIR}
   ${PROJECT_BINARY_DIR}/idl
   ${PROJECT_BINARY_DIR}/adm_local/unix
+  ${PROJECT_SOURCE_DIR}/src/FrontTrack
   ${PROJECT_SOURCE_DIR}/src/HOMARD
   ${PROJECT_SOURCE_DIR}/src/HOMARDGUI
 )
@@ -48,6 +49,8 @@ SET(_link_LIBRARIES
   ${KERNEL_TOOLSDS}
   ${KERNEL_SalomeGenericObj}
   ${SMESH_SalomeIDLSMESH}
+  ${SMESH_SMESHEngine}
+  FrontTrack
   SalomeIDLHOMARD
   HOMARDImpl
 )
@@ -61,10 +64,12 @@ SET(HOMARDEngine_HEADERS
   HOMARD_Iteration_i.hxx
   HOMARD_Zone_i.hxx
   HOMARD_Gen_i.hxx
+  HOMARD_Gen_i_Session.hxx
+  HOMARD_Gen_i_No_Session.hxx
   HOMARD_Boundary_i.hxx
   HOMARD_YACS_i.hxx
   HomardMedCommun.h
-  HOMARD_i.hxx 
+  HOMARD_i.hxx
 )
 
 # --- sources ---
@@ -75,6 +80,8 @@ SET(HOMARDEngine_SOURCES
   HOMARD_Hypothesis_i.cxx
   HOMARD_Iteration_i.cxx
   HOMARD_Gen_i.cxx
+  HOMARD_Gen_i_Session.cxx
+  HOMARD_Gen_i_No_Session.cxx
   HOMARD_Zone_i.cxx
   HOMARD_Boundary_i.cxx
   HOMARD_YACS_i.cxx
@@ -87,4 +94,4 @@ ADD_LIBRARY(HOMARDEngine ${HOMARDEngine_SOURCES})
 TARGET_LINK_LIBRARIES(HOMARDEngine ${_link_LIBRARIES} )
 INSTALL(TARGETS HOMARDEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
-INSTALL(FILES ${HOMARDEngine_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})
\ No newline at end of file
+INSTALL(FILES ${HOMARDEngine_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})