Salome HOME
Updated copyright comment
[modules/homard.git] / src / HOMARDGUI / CMakeLists.txt
old mode 100755 (executable)
new mode 100644 (file)
index d0e02f7..811da6e
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2014  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2024  CEA, EDF
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
-INCLUDE(UseQt4Ext)
-INCLUDE(UsePyQt4)
+INCLUDE(UseQtExt)
+INCLUDE(UsePyQt)
 
 # --- options ---
+
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${QT_INCLUDES}
-  ${CAS_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${PYTHON_INCLUDE_DIRS}
   ${MEDFILE_INCLUDE_DIRS}
   ${HDF5_INCLUDE_DIRS}
-  ${Boost_INCLUDE_DIRS}
   ${OMNIORB_INCLUDE_DIR}
   ${KERNEL_INCLUDE_DIRS}
   ${GUI_INCLUDE_DIRS}
   ${CMAKE_CURRENT_SOURCE_DIR}
+  ${CMAKE_CURRENT_BINARY_DIR}
   ${PROJECT_BINARY_DIR}
   ${PROJECT_BINARY_DIR}/idl
   ${PROJECT_BINARY_DIR}/adm_local/unix
   ${PROJECT_SOURCE_DIR}/src/HOMARD
   ${PROJECT_SOURCE_DIR}/src/HOMARD_I
+  ${PROJECT_SOURCE_DIR}/src/FrontTrack
 )
 
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
-  ${BOOST_DEFINITIONS}
   ${OMNIORB_DEFINITIONS}
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${KERNEL_DEFINITIONS}
 )
 
@@ -58,14 +59,42 @@ SET(_link_LIBRARIES
   HOMARDEngine
 )
 
+# --- resources ---
+
+# resource files / to be processed by lrelease
+SET(_ts_RESOURCES
+  HOMARD_msg_en.ts
+  HOMARD_msg_fr.ts
+  HOMARD_msg_ja.ts
+)
+
+# resource files / to be processed by uic
+SET(_uic_FILES
+  CreateBoundaryCAO.ui
+  CreateBoundaryAn.ui
+  CreateBoundaryDi.ui
+  CreateCase.ui
+  CreateHypothesis.ui
+  CreateIteration.ui
+  CreateListGroup.ui
+  CreateYACS.ui
+  CreateZone.ui
+  EditFile.ui
+  IterInfo.ui
+  MeshInfo.ui
+  PursueIteration.ui
+)
+
 # --- headers ---
 
 # header files / to be processed by moc
 SET(_moc_HEADERS
   HOMARDGUI.h
+  MonCreateBoundaryCAO.h
   MonCreateBoundaryAn.h
-  MonEditBoundaryAn.h
   MonCreateBoundaryDi.h
+  MonEditBoundaryCAO.h
+  MonEditBoundaryAn.h
   MonEditBoundaryDi.h
   MonCreateCase.h
   MonEditCase.h
@@ -74,7 +103,9 @@ SET(_moc_HEADERS
   MonCreateHypothesis.h
   MonEditHypothesis.h
   MonCreateListGroup.h
+  MonCreateListGroupCAO.h
   MonEditListGroup.h
+  MonEditListGroupCAO.h
   MonCreateIteration.h
   MonEditIteration.h
   MonPursueIteration.h
@@ -85,47 +116,42 @@ SET(_moc_HEADERS
   MonEditFile.h
 )
 
-# header files / no moc processing
+# header files / uic wrappings
+QT_WRAP_UIC(_uic_HEADERS ${_uic_FILES})
+
+# header files / static
 SET(_other_HEADERS
-  CreateBoundaryAn.h
-  CreateBoundaryDi.h
-  CreateCase.h
-  CreateZone.h
-  CreateHypothesis.h
-  CreateListGroup.h
-  CreateIteration.h
-  PursueIteration.h
-  MeshInfo.h
-  IterInfo.h
-  CreateYACS.h
   HOMARDGUI_Utils.h
-  EditFile.h
   HomardQtCommun.h
   HOMARDGUI_Exports.hxx
 )
 
 # header files / to install
-SET(HOMARD_HEADERS ${_other_HEADERS} ${_moc_HEADERS})
+SET(HOMARD_HEADERS ${_other_HEADERS} ${_moc_HEADERS} ${_uic_HEADERS})
 
 # --- sources ---
 
 # sources / moc wrappings
-QT4_WRAP_CPP(_moc_SOURCES ${_moc_HEADERS})
+QT_WRAP_MOC(_moc_SOURCES ${_moc_HEADERS})
 
 # sources / static
 SET(_other_SOURCES
   HOMARDGUI.cxx
   HOMARDGUI_Utils.cxx
+  MonCreateBoundaryCAO.cxx
   MonCreateBoundaryAn.cxx
-  MonEditBoundaryAn.cxx
   MonCreateBoundaryDi.cxx
+  MonEditBoundaryCAO.cxx
+  MonEditBoundaryAn.cxx
   MonEditBoundaryDi.cxx
   MonCreateCase.cxx
   MonEditCase.cxx
   MonCreateHypothesis.cxx
   MonEditHypothesis.cxx
   MonCreateListGroup.cxx
+  MonCreateListGroupCAO.cxx
   MonEditListGroup.cxx
+  MonEditListGroupCAO.cxx
   MonCreateIteration.cxx
   MonEditIteration.cxx
   MonPursueIteration.cxx
@@ -140,36 +166,7 @@ SET(_other_SOURCES
 )
 
 # sources / to compile
-SET(HOMARD_SOURCES ${_other_SOURCES} ${_moc_SOURCES})
-
-# --- resources ---
-
-# resource files / to be processed by lrelease
-SET(_ts_RESOURCES
-  HOMARD_msg_en.ts
-  HOMARD_msg_fr.ts
-  HOMARD_msg_ja.ts
-) 
-
-# no install files
-# uic files / to be processed by pyuic
-SET(_pyuic_files
-  CreateBoundaryAn.ui
-  CreateBoundaryDi.ui
-  CreateCase.ui
-  CreateHypothesis.ui
-  CreateIteration.ui
-  CreateListGroup.ui
-  CreateZone.ui
-  PursueIteration.ui
-  MeshInfo.ui
-  IterInfo.ui
-  CreateYACS.ui
-  EditFile.ui
-)
-
-# scripts / pyuic wrappings
-PYQT4_WRAP_UIC(_pyuic_SCRIPTS ${_pyuic_files})
+SET(HOMARD_SOURCES ${_other_SOURCES} ${_moc_SOURCES} ${_uic_HEADERS})
 
 # --- rules ---
 
@@ -178,4 +175,4 @@ TARGET_LINK_LIBRARIES(HOMARD ${_link_LIBRARIES} )
 INSTALL(TARGETS HOMARD EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
 INSTALL(FILES ${HOMARD_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})
-QT4_INSTALL_TS_RESOURCES("${_ts_RESOURCES}" "${SALOME_HOMARD_INSTALL_RES_DATA}")
+QT_INSTALL_TS_RESOURCES("${_ts_RESOURCES}" "${SALOME_HOMARD_INSTALL_RES_DATA}")