Salome HOME
[bos #29473] [EDF] (2022-T1) Advanced geometry features: conformity of non holed...
[modules/geom.git] / src / GEOMImpl / CMakeLists.txt
index 26d37c40f7c038220227d5482f9e725b8bd0c555..6dbbae81ed19136ec63e2e9be83fafebe878ad65 100644 (file)
@@ -93,6 +93,7 @@ SET(GEOMImpl_HEADERS
   GEOMImpl_IDisk.hxx
   GEOMImpl_IFace.hxx
   GEOMImpl_ILine.hxx
+  GEOMImpl_IPatchFace.hxx
   GEOMImpl_IPlane.hxx
   GEOMImpl_IMarker.hxx
   GEOMImpl_ITranslate.hxx
@@ -119,6 +120,7 @@ SET(GEOMImpl_HEADERS
   GEOMImpl_IPipePath.hxx
   GEOMImpl_IRevolution.hxx
   GEOMImpl_IMeasure.hxx
+  GEOMImpl_IConformity.hxx
   GEOMImpl_IShapes.hxx
   GEOMImpl_IShapeExtend.hxx
   GEOMImpl_IFilling.hxx
@@ -155,6 +157,7 @@ SET(GEOMImpl_HEADERS
   GEOMImpl_BlockDriver.hxx
   GEOMImpl_Block6Explorer.hxx
   GEOMImpl_MeasureDriver.hxx
+  GEOMImpl_ConformityDriver.hxx
   GEOMImpl_PolylineDriver.hxx
   GEOMImpl_PolylineDumper.hxx
   GEOMImpl_CircleDriver.hxx
@@ -178,8 +181,10 @@ SET(GEOMImpl_HEADERS
   GEOMImpl_HealingDriver.hxx
   GEOMImpl_FillingDriver.hxx
   GEOMImpl_GlueDriver.hxx
+  GEOMImpl_PatchFaceDriver.hxx
   GEOMImpl_Types.hxx
   GEOM_GEOMImpl.hxx
+  GEOMImpl_ICanonicalRecognition.hxx
   )
 # --- sources ---
 
@@ -202,6 +207,7 @@ SET(GEOMImpl_SOURCES
   GEOMImpl_ITestOperations.cxx
   GEOMImpl_IPolyline2D.cxx
   GEOMImpl_ITransferData.cxx
+  GEOMImpl_IConformity.cxx
   GEOMImpl_Gen.cxx
   GEOMImpl_PointDriver.cxx
   GEOMImpl_VectorDriver.cxx
@@ -230,6 +236,7 @@ SET(GEOMImpl_SOURCES
   GEOMImpl_BlockDriver.cxx
   GEOMImpl_Block6Explorer.cxx
   GEOMImpl_MeasureDriver.cxx
+  GEOMImpl_ConformityDriver.cxx
   GEOMImpl_PolylineDriver.cxx
   GEOMImpl_PolylineDumper.cxx
   GEOMImpl_CircleDriver.cxx
@@ -253,7 +260,9 @@ SET(GEOMImpl_SOURCES
   GEOMImpl_HealingDriver.cxx
   GEOMImpl_FillingDriver.cxx
   GEOMImpl_GlueDriver.cxx
+  GEOMImpl_PatchFaceDriver.cxx
   GEOMImpl_FieldDriver.cxx
+  GEOMImpl_ICanonicalRecognition.cxx
   )
 
 # --- rules ---