Salome HOME
Added new cmake test targets
[tools/solverlab.git] / CDMATH / cdmath.spec
1 # -*- rpm-spec -*-
2 BuildRoot:      /tmp
3 Summary:        Numerical Analysis toolbox
4 Name:           cdmath
5 Version:        0.4
6 Release:        1
7 License:        Open Source
8 Group:          Development/Science
9 Vendor:         CEA Saclay
10 Packager:       Michael Ndjinga <firstname.lastname@cea.fr>
11 Source:         cdmath-%{version}.tar.gz
12 URL:            https://github.com/mndjinga/CDMATH/archive/master.zip
13
14 BuildRequires:  cmake, gcc-c++, hdf5-devel, petsc-devel, openmpi-devel
15 Requires:               hdf5, petsc, openmpi
16
17 %description
18 CDMATH is a geometrical and numerical toolbox designed for numerical analysts who work on the discretisation of partial differential equations on general shapes and meshes and who would rather focus on high-level scripting of finite elements and finite volume methods. The library originates from [CDMATH](http://cdmath.jimdo.com), a collaborative workgroup with the same name. It is based on the [MEDcoupling](http://docs.salome-platform.org/latest/dev/MEDCoupling/index.html) library of the [SALOME](http://www.salome-platform.org/) project for the handling of meshes and fields, and on the library [PETSC](https://www.mcs.anl.gov/petsc/) for the handling of matrices and linear solvers.
19
20 %prep
21 %setup -q
22
23 %build
24 cmake -DCMAKE_INSTALL_PREFIX=/opt -DCMAKE_BUILD_TYPE=Release .
25 make
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 make install DESTDIR=$RPM_BUILD_ROOT
30
31 %clean
32 rm -rf $RPM_BUILD_ROOT
33
34 %post
35
36 %postun
37
38 %pre
39
40 %preun
41
42 %files
43 %defattr(-,root,root,-)
44 "/opt/lib/libinterpkernel.so"
45 "/opt/lib/libbase.so"
46 "/opt/lib/libmedcoupling.so"
47 "/opt/lib/libmesh.so"
48 "/opt/lib/libmedcouplingremapper.so"
49 "/opt/lib/libmedloader.so"
50 "/opt/lib/libmedC.so"
51 %dir "/opt/share/cmake"
52 %dir "/opt/share/cmake/MEDFile"
53 "/opt/share/cmake/MEDFile/MEDFileConfig.cmake"
54 "/opt/share/cmake/MEDFile/MEDFileConfigVersion.cmake"
55 %dir "/opt/share/doc/cdmath"
56 %dir "/opt/share/doc/cdmath/examples"
57 %dir "/opt/share/doc/cdmath/examples/thermique1d"
58 "/opt/share/doc/cdmath/examples/thermique1d/makefile"
59 "/opt/share/doc/cdmath/examples/thermique1d/main.cxx"
60 %dir "/opt/share/doc/cdmath/examples/transport2d_ns"
61 "/opt/share/doc/cdmath/examples/transport2d_ns/main2.cxx"
62 "/opt/share/doc/cdmath/examples/transport2d_ns/MeshTri.med"
63 "/opt/share/doc/cdmath/examples/transport2d_ns/makefile"
64 "/opt/share/doc/cdmath/examples/transport2d_ns/main.py"
65 "/opt/share/doc/cdmath/examples/transport2d_ns/main.cxx"
66 %dir "/opt/share/doc/cdmath/examples/transport2d_s"
67 "/opt/share/doc/cdmath/examples/transport2d_s/makefile"
68 "/opt/share/doc/cdmath/examples/transport2d_s/main.py"
69 "/opt/share/doc/cdmath/examples/transport2d_s/main.cxx"
70 %dir "/opt/share/doc/cdmath/examples/transport1d"
71 "/opt/share/doc/cdmath/examples/transport1d/makefile"
72 "/opt/share/doc/cdmath/examples/transport1d/main.py"
73 "/opt/share/doc/cdmath/examples/transport1d/main.cxx"
74 "/opt/include/MEDCouplingNormalizedCartesianMesh.txx"
75 "/opt/include/InterpKernelGeo2DEdgeLin.hxx"
76 "/opt/include/TargetIntersector.hxx"
77 "/opt/include/MEDCouplingDefinitionTime.hxx"
78 "/opt/include/CurveIntersectorP1P1.txx"
79 "/opt/include/InterpKernelMatrix.hxx"
80 "/opt/include/medlibrary.h"
81 "/opt/include/PolyhedronIntersectorP1P1.txx"
82 "/opt/include/Barycentric3DIntersectorP1P1.txx"
83 "/opt/include/CurveIntersector.hxx"
84 "/opt/include/InterpKernelStlExt.hxx"
85 "/opt/include/DoubleTab.hxx"
86 "/opt/include/MEDCouplingFieldOverTime.hxx"
87 "/opt/include/MeshRegion.txx"
88 "/opt/include/GenMathFormulae.hxx"
89 "/opt/include/IntTab.hxx"
90 "/opt/include/MEDCouplingCartesianAMRMesh.hxx"
91 "/opt/include/Log.hxx"
92 "/opt/include/MEDLoaderBase.hxx"
93 "/opt/include/SauvReader.hxx"
94 "/opt/include/medfilter.h"
95 "/opt/include/medlink.h"
96 "/opt/include/VolSurfFormulae.hxx"
97 "/opt/include/PlanarIntersectorP0P0.txx"
98 "/opt/include/InterpKernelGeo2DQuadraticPolygon.hxx"
99 "/opt/include/TransformedTriangleInline.hxx"
100 "/opt/include/PlanarIntersectorP1P0.hxx"
101 "/opt/include/NormalizedGeometricTypes"
102 %dir "/opt/include/2.3.6"
103 "/opt/include/2.3.6/med23v30_proto.h"
104 "/opt/include/2.3.6/medC_win_dll.h"
105 "/opt/include/2.3.6/MEDerreur.hxx"
106 "/opt/include/2.3.6/med_utils.h"
107 "/opt/include/2.3.6/med_exit_if.h"
108 "/opt/include/2.3.6/med.h"
109 "/opt/include/2.3.6/med23v30.h"
110 "/opt/include/2.3.6/med.hf"
111 "/opt/include/2.3.6/med_proto.h"
112 "/opt/include/InterpKernelFunction.hxx"
113 "/opt/include/Interpolation3D2D.txx"
114 "/opt/include/BBTreeDst.txx"
115 "/opt/include/MEDCouplingMesh.hxx"
116 "/opt/include/Interpolation3DSurf.hxx"
117 "/opt/include/InterpKernelAutoPtr.hxx"
118 "/opt/include/MEDFileField.hxx"
119 "/opt/include/InterpKernelMatrixTools.hxx"
120 "/opt/include/CurveIntersectorP0P1.hxx"
121 "/opt/include/InterpKernelExprParser.hxx"
122 "/opt/include/PolygonAlgorithms.hxx"
123 "/opt/include/MEDCouplingAMRAttribute.hxx"
124 "/opt/include/MEDCouplingTimeDiscretization.hxx"
125 "/opt/include/INTERPKERNELDefines.hxx"
126 "/opt/include/Mesh.hxx"
127 "/opt/include/MEDFileFieldOverView.hxx"
128 "/opt/include/InterpKernelGaussCoords.hxx"
129 "/opt/include/Interpolation.hxx"
130 "/opt/include/MEDFileMeshReadSelector.hxx"
131 "/opt/include/Interpolation3D.hxx"
132 "/opt/include/Interpolation3D.txx"
133 "/opt/include/IntersectorCU3D.txx"
134 "/opt/include/SauvUtilities.hxx"
135 "/opt/include/InterpKernelGeo2DComposedEdge.hxx"
136 "/opt/include/GenericMatrix.hxx"
137 "/opt/include/PointLocatorAlgos.txx"
138 "/opt/include/CurveIntersectorP1P0.txx"
139 "/opt/include/Interpolation1D.hxx"
140 "/opt/include/PointLocator3DIntersectorP1P1.txx"
141 "/opt/include/MEDCouplingFieldDouble.hxx"
142 "/opt/include/BoxSplittingOptions.hxx"
143 "/opt/include/Polyhedron3D2DIntersectorP0P0.txx"
144 "/opt/include/InterpolationCurve.txx"
145 "/opt/include/InterpKernelGeo2DEdge.txx"
146 "/opt/include/Intersector3DP0P0.txx"
147 "/opt/include/Intersector3D.hxx"
148 "/opt/include/PointLocator3DIntersectorP0P1.hxx"
149 "/opt/include/Intersector3DP1P1.txx"
150 "/opt/include/PlanarIntersectorP0P1PL.txx"
151 "/opt/include/PlanarIntersectorP0P0.hxx"
152 "/opt/include/IntersectorCU.hxx"
153 "/opt/include/MEDCouplingRemapper.hxx"
154 "/opt/include/medC_win_dll.h"
155 "/opt/include/InterpKernelAsmX86.hxx"
156 "/opt/include/IntersectorCU2D.hxx"
157 "/opt/include/Matrix.hxx"
158 "/opt/include/MEDCouplingMatrix.hxx"
159 "/opt/include/PointLocator2DIntersector.txx"
160 "/opt/include/med.hf77"
161 "/opt/include/InterpolationPlanar.hxx"
162 "/opt/include/PlanarIntersectorP0P1Bary.txx"
163 "/opt/include/MEDCouplingRefCountObject.hxx"
164 "/opt/include/MEDCouplingAutoRefCountObjectPtr.hxx"
165 "/opt/include/InterpKernelValue.hxx"
166 "/opt/include/ConvexIntersector.txx"
167 "/opt/include/Cell.hxx"
168 "/opt/include/Interpolation2DCurve.hxx"
169 "/opt/include/InterpolationOptions.hxx"
170 "/opt/include/Intersector3DP1P1.hxx"
171 "/opt/include/PolyhedronIntersectorP1P0Bary.txx"
172 "/opt/include/PolyhedronIntersectorP1P0Bary.hxx"
173 "/opt/include/InterpKernelHashMap.hxx"
174 "/opt/include/Intersector3DP1P0Bary.txx"
175 "/opt/include/InterpKernelGeo2DPrecision.hxx"
176 "/opt/include/InterpolationCurve.hxx"
177 "/opt/include/PlanarIntersectorP1P1.hxx"
178 "/opt/include/CurveIntersector.txx"
179 "/opt/include/TetraAffineTransform.hxx"
180 "/opt/include/med_err.h"
181 "/opt/include/PolyhedronIntersectorP1P0.txx"
182 "/opt/include/InterpKernelGeo2DAbstractEdge.hxx"
183 "/opt/include/medparameter.h"
184 "/opt/include/PolyhedronIntersectorP0P0.hxx"
185 "/opt/include/VTKNormalizedUnstructuredMesh.txx"
186 "/opt/include/UnitTetraIntersectionBary.hxx"
187 "/opt/include/PlanarIntersectorP0P1.hxx"
188 "/opt/include/MEDCouplingExtrudedMesh.hxx"
189 "/opt/include/IntersectorCU1D.txx"
190 "/opt/include/MEDCoupling.hxx"
191 "/opt/include/CurveIntersectorP1P0.hxx"
192 "/opt/include/InterpKernelGeo2DEdgeArcCircle.hxx"
193 "/opt/include/PlanarIntersectorP1P1.txx"
194 "/opt/include/MEDCouplingNormalizedCartesianMesh.hxx"
195 "/opt/include/InterpolationCC.hxx"
196 "/opt/include/TranslationRotationMatrix.hxx"
197 "/opt/include/PolygonAlgorithms.txx"
198 "/opt/include/MEDFileParameter.hxx"
199 "/opt/include/medinterp.h"
200 "/opt/include/PointLocator3DIntersectorP1P1.hxx"
201 "/opt/include/PlanarIntersectorP1P0.txx"
202 "/opt/include/InterpKernelGeo2DBounds.hxx"
203 "/opt/include/InterpKernelException.hxx"
204 "/opt/include/IntegralUniformIntersector.txx"
205 "/opt/include/PolyhedronIntersectorP1P0.hxx"
206 "/opt/include/InterpKernelHashTable.hxx"
207 "/opt/include/PolyhedronIntersectorP0P1.txx"
208 "/opt/include/MEDCouplingMultiFields.hxx"
209 "/opt/include/MEDFileBasis.hxx"
210 "/opt/include/BBTreePts.txx"
211 "/opt/include/PlanarIntersectorP1P0PL.txx"
212 "/opt/include/PlanarIntersectorP1P1PL.txx"
213 "/opt/include/MEDCouplingField.hxx"
214 "/opt/include/InterpolationUtils.hxx"
215 "/opt/include/CellModel.hxx"
216 "/opt/include/Intersector3DP0P0.hxx"
217 "/opt/include/MEDCouplingStructuredMesh.hxx"
218 "/opt/include/SparseMatrix.hxx"
219 "/opt/include/MEDerreur.hxx"
220 "/opt/include/med_utils.h"
221 "/opt/include/medfield.h"
222 "/opt/include/Barycentric3DIntersectorP1P1.hxx"
223 "/opt/include/IntegralUniformIntersector.hxx"
224 "/opt/include/Intersector3DP0P1.hxx"
225 "/opt/include/PlanarIntersectorP1P0Bary.hxx"
226 "/opt/include/TriangulationIntersector.hxx"
227 "/opt/include/CurveIntersectorP0P1.txx"
228 "/opt/include/PointLocator3DIntersectorP0P0.txx"
229 "/opt/include/InterpKernelUtilities.hxx"
230 "/opt/include/MEDCouplingNatureOfField.hxx"
231 "/opt/include/PlanarIntersectorP0P1PL.hxx"
232 "/opt/include/SauvWriter.hxx"
233 "/opt/include/InterpolationCU.txx"
234 "/opt/include/medequivalence.h"
235 "/opt/include/medsubdomain.h"
236 "/opt/include/ConvexIntersector.hxx"
237 "/opt/include/VolSurfUser.hxx"
238 "/opt/include/Planar2D1DIntersectorP0P0.txx"
239 "/opt/include/PolyhedronIntersectorP0P0.txx"
240 "/opt/include/InterpKernelCellSimplify.hxx"
241 "/opt/include/Vector.hxx"
242 "/opt/include/MEDCouplingCurveLinearMesh.hxx"
243 "/opt/include/MEDCouplingGaussLocalization.hxx"
244 "/opt/include/InterpKernelGeo2DNode.hxx"
245 "/opt/include/med_parameter.hf"
246 "/opt/include/MEDLoaderDefines.hxx"
247 "/opt/include/Intersector3DP1P0Bary.hxx"
248 "/opt/include/MeshRegion.hxx"
249 "/opt/include/CurveIntersectorP0P0.hxx"
250 "/opt/include/DirectedBoundingBox.hxx"
251 "/opt/include/InterpKernelUnit.hxx"
252 "/opt/include/MeshElement.txx"
253 "/opt/include/MEDCouplingUMesh.hxx"
254 "/opt/include/SplitterTetra.hxx"
255 "/opt/include/SplitterTetra.txx"
256 "/opt/include/MeshElement.hxx"
257 "/opt/include/med_exit_if.h"
258 "/opt/include/med.hf90"
259 "/opt/include/InterpolationPlanar.txx"
260 "/opt/include/PointLocator3DIntersectorP0P1.txx"
261 "/opt/include/Intersector3D.txx"
262 "/opt/include/MEDFileMeshElt.hxx"
263 "/opt/include/medfile.h"
264 "/opt/include/Geometric2DIntersector.hxx"
265 "/opt/include/MEDCouplingNatureOfFieldEnum"
266 "/opt/include/Planar2D1DIntersectorP0P0.hxx"
267 "/opt/include/PlanarIntersectorP1P1PL.hxx"
268 "/opt/include/MEDFileData.hxx"
269 "/opt/include/CurveIntersectorP1P1.hxx"
270 "/opt/include/Interpolation2D1D.txx"
271 "/opt/include/PolyhedronIntersectorP1P1.hxx"
272 "/opt/include/IntersectorCU.txx"
273 "/opt/include/PlanarIntersectorP1P0PL.hxx"
274 "/opt/include/medprofile.h"
275 "/opt/include/RegionNode.hxx"
276 "/opt/include/SauvMedConvertor.hxx"
277 "/opt/include/MEDLoader.hxx"
278 "/opt/include/MEDCouplingPointSet.hxx"
279 "/opt/include/medlocalization.h"
280 "/opt/include/med.h"
281 "/opt/include/VolSurfUser.txx"
282 "/opt/include/IntersectorCU1D.hxx"
283 "/opt/include/Interpolation.txx"
284 "/opt/include/InterpKernelGeo2DEdgeInfLin.hxx"
285 "/opt/include/IntersectorCU3D.hxx"
286 "/opt/include/Intersector3DP0P1.txx"
287 "/opt/include/InterpKernelMeshQuality.hxx"
288 "/opt/include/Face.hxx"
289 "/opt/include/InterpolationCU.hxx"
290 "/opt/include/Interpolation3D2D.hxx"
291 "/opt/include/InterpolationCC.txx"
292 "/opt/include/Point.hxx"
293 "/opt/include/PolyhedronIntersectorP0P1.hxx"
294 "/opt/include/TransformedTriangle.hxx"
295 "/opt/include/PlanarIntersectorP1P0Bary.txx"
296 "/opt/include/NormalizedUnstructuredMesh.hxx"
297 "/opt/include/MEDCouplingFieldDiscretization.hxx"
298 "/opt/include/Interpolation1D.txx"
299 "/opt/include/PointLocator3DIntersectorP0P0.hxx"
300 "/opt/include/PointLocator2DIntersector.hxx"
301 "/opt/include/MEDCouplingMemArray.txx"
302 "/opt/include/Intersector3DP1P0.txx"
303 "/opt/include/PlanarIntersectorP0P1Bary.hxx"
304 "/opt/include/MEDCouplingNormalizedUnstructuredMesh.hxx"
305 "/opt/include/Interpolation2D1D.hxx"
306 "/opt/include/TriangulationIntersector.txx"
307 "/opt/include/MeshUtils.hxx"
308 "/opt/include/PlanarIntersectorP0P1.txx"
309 "/opt/include/VectorUtils.hxx"
310 "/opt/include/Interpolation2D.txx"
311 "/opt/include/MEDFileMeshLL.hxx"
312 "/opt/include/CdmathException.hxx"
313 "/opt/include/IntersectorCU2D.txx"
314 "/opt/include/InterpKernelGeo2DElementaryEdge.hxx"
315 "/opt/include/PointLocator3DIntersectorP1P0.txx"
316 "/opt/include/VTKNormalizedUnstructuredMesh.hxx"
317 "/opt/include/Intersector3DP1P0.hxx"
318 "/opt/include/MEDFileMesh.hxx"
319 "/opt/include/Field.hxx"
320 "/opt/include/Node.hxx"
321 "/opt/include/PlanarIntersector.txx"
322 "/opt/include/PlanarIntersector.hxx"
323 "/opt/include/MEDFileUtilities.hxx"
324 "/opt/include/InterpKernelGeo2DEdge.hxx"
325 "/opt/include/Interpolation2D.hxx"
326 "/opt/include/med.hf"
327 "/opt/include/MEDCouplingNormalizedUnstructuredMesh.txx"
328 "/opt/include/PointLocator3DIntersectorP1P0.hxx"
329 "/opt/include/MEDCouplingMemArray.hxx"
330 "/opt/include/medmesh.h"
331 "/opt/include/Polyhedron3D2DIntersectorP0P0.hxx"
332 "/opt/include/MEDCouplingFieldTemplate.hxx"
333 "/opt/include/BBTree.txx"
334 "/opt/include/MEDCoupling1GTUMesh.hxx"
335 "/opt/include/Geometric2DIntersector.txx"
336 "/opt/include/CurveIntersectorP0P0.txx"
337 "/opt/include/MEDCouplingTimeLabel.hxx"
338 "/opt/include/med_proto.h"
339 "/opt/include/InterpKernelHashFun.hxx"
340 "/opt/include/BoundingBox.hxx"
341 "/opt/include/MEDCouplingIMesh.hxx"
342 "/opt/include/MEDCouplingCMesh.hxx"
343 "/opt/include/medfamily.h"
344