Salome HOME
Merge from BR_V5_DEV 16Feb09
[modules/smesh.git] / doc / salome / gui / Makefile.am
index 66ce3648ef1f7709880262fa8c29ec88d52903c6..0e41ee5ff42a7bb1fa557a8ba0eca1bee931e84b 100644 (file)
@@ -1,4 +1,7 @@
-#  Copyright (C) 2005  CEA/DEN, EDF R&D, OPEN CASCADE, PRINCIPIA R&D
+#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+#
+#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
+#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
 #
 #  This library is free software; you can redistribute it and/or
 #  modify it under the terms of the GNU Lesser General Public
 #  Author : Vasily Rusyaev (Open Cascade NN)
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : doc
-
+#
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
-EXTRA_DIST+=SMESH
+SUBDIRS = SMESH
 
-doxygen=@DOXYGEN@
-
-# Below command replaces "smeshDC" by "smesh" except cases
-# "ssmeshDC", "1smeshDC" and "esmeshDC" (these sequences
-# can be found in file names and must not be replaces):
-#
-# sed 's/\([^s1e]\)smeshDC\|^smeshDC/\1smesh/g' $${filen} > ./tmp;
-#
 usr_docs:
-       cd ./SMESH; \
-       echo "Processing smeshDC.py file: "; \
-       $(doxygen) ./doxyfile_py; \
-       cd ./smeshpy_doc; \
-       filesl=`find .`; \
-       for filen in $${filesl}; do \
-         sed 's/\([^s1e]\)smeshDC\|^smeshDC/\1smesh/g' $${filen} > ./tmp; \
-         mv -f tmp $${filen}; \
-       done; \
-       cd ..; \
-       echo "Running doxygen in directory: "`pwd`; \
-       $(doxygen) ./doxyfile;
+       (cd SMESH && $(MAKE) $(AM_MAKEFLAGS) usr_docs)
 
 docs: usr_docs
-
-clean-local:
-       rm -fr `ls | grep -v "Makefile"`
-       rm -fr SMESH
-
-install-data-local: usr_docs
-       mkdir -p $(docdir)/gui
-       cp -rf SMESH $(docdir)/gui
-       -find $(PWD) -name CVS -prune -exec rm -rf {} \;
-
-uninstall-local:
-       rm -rf $(docdir)/gui/SMESH
-
-docguidir=$(docdir)/gui/SMESH
-
-nodist_docgui_DATA= SMESH/doxyfile
-nodist_docgui_DATA+= SMESH/doxyfile_py
-EXTRA_DIST+= SMESH/doxyfile.in
-EXTRA_DIST+= SMESH/doxyfile_py.in